summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-https_dns_proxy/Makefile17
-rw-r--r--applications/luci-app-https_dns_proxy/luasrc/controller/https_dns_proxy.lua7
-rw-r--r--applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua53
-rw-r--r--applications/luci-app-https_dns_proxy/po/templates/https_dns_proxy.pot2
-rw-r--r--applications/luci-app-https_dns_proxy/root/etc/uci-defaults/40_luci-https_dns_proxy10
5 files changed, 89 insertions, 0 deletions
diff --git a/applications/luci-app-https_dns_proxy/Makefile b/applications/luci-app-https_dns_proxy/Makefile
new file mode 100644
index 000000000..2ae2b80f2
--- /dev/null
+++ b/applications/luci-app-https_dns_proxy/Makefile
@@ -0,0 +1,17 @@
+# Copyright 2017-2018 Stan Grishin (stangri@melmac.net)
+# This is free software, licensed under the GNU General Public License v3.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-3.0+
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
+
+LUCI_TITLE:=HTTPS DNS Proxy Web UI
+LUCI_DESCRIPTION:=Provides Web UI for HTTPS DNS Proxy
+LUCI_DEPENDS:=+luci-mod-admin-full +https_dns_proxy
+LUCI_PKGARCH:=all
+PKG_RELEASE:=2
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-https_dns_proxy/luasrc/controller/https_dns_proxy.lua b/applications/luci-app-https_dns_proxy/luasrc/controller/https_dns_proxy.lua
new file mode 100644
index 000000000..e1fd8fcb9
--- /dev/null
+++ b/applications/luci-app-https_dns_proxy/luasrc/controller/https_dns_proxy.lua
@@ -0,0 +1,7 @@
+module("luci.controller.https_dns_proxy", package.seeall)
+function index()
+ if not nixio.fs.access("/etc/config/https_dns_proxy") then
+ return
+ end
+ entry({"admin", "services", "https_dns_proxy"}, cbi("https_dns_proxy"), _("HTTPS DNS Proxy"))
+end
diff --git a/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua b/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua
new file mode 100644
index 000000000..61511a413
--- /dev/null
+++ b/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua
@@ -0,0 +1,53 @@
+local uci = require("luci.model.uci").cursor()
+
+m = Map("https_dns_proxy", translate("HTTPS DNS Proxy Settings"))
+m.template="cbi/map"
+
+s3 = m:section(TypedSection, "https_dns_proxy", translate("Instances"))
+s3.template = "cbi/tblsection"
+s3.sortable = false
+s3.anonymous = true
+s3.addremove = true
+
+prov = s3:option(ListValue, "url_prefix", translate("Provider"))
+prov:value("https://cloudflare-dns.com/dns-query?ct=application/dns-json&","Cloudflare")
+prov:value("https://dns.google.com/resolve?","Google")
+prov.write = function(self, section, value)
+ if value and value:match("cloudflare") then
+ uci:set("https_dns_proxy", section, "bootstrap_dns", "1.1.1.1,1.0.0.1")
+ uci:set("https_dns_proxy", section, "url_prefix", "https://cloudflare-dns.com/dns-query?ct=application/dns-json&")
+ else
+ uci:set("https_dns_proxy", section, "bootstrap_dns", "8.8.8.8,8.8.4.4")
+ uci:set("https_dns_proxy", section, "url_prefix", "https://dns.google.com/resolve?")
+ end
+ uci:set("https_dns_proxy", section, "user", "nobody")
+ uci:set("https_dns_proxy", section, "group", "nogroup")
+ uci:save("https_dns_proxy")
+end
+
+la = s3:option(Value, "listen_addr", translate("Listen address"))
+la.value = "127.0.0.1"
+la.rmempty = true
+
+lp = s3:option(Value, "listen_port", translate("Listen port"))
+lp.datatype = "port"
+lp.placeholder = "5053"
+lp.rmempty = true
+
+-- user = s3:option(Value, "user", translate("User name"))
+-- user.placeholder = "nobody"
+-- user.rmempty = true
+
+-- group = s3:option(Value, "group", translate("Group name"))
+-- group.placeholder = "nogroup"
+-- group.rmempty = true
+
+sa = s3:option(Value, "subnet_addr", translate("Subnet address"))
+sa.datatype = "ip4prefix"
+sa.rmempty = true
+
+ps = s3:option(Value, "proxy_server", translate("Proxy server"))
+-- ps.datatype = "or(ipaddr,hostname)"
+ps.rmempty = true
+
+return m
diff --git a/applications/luci-app-https_dns_proxy/po/templates/https_dns_proxy.pot b/applications/luci-app-https_dns_proxy/po/templates/https_dns_proxy.pot
new file mode 100644
index 000000000..1b0b66aae
--- /dev/null
+++ b/applications/luci-app-https_dns_proxy/po/templates/https_dns_proxy.pot
@@ -0,0 +1,2 @@
+Set up git to auto-update pot-file:
+echo '../i18n-scan.pl luci-app-template/ > luci-app-template/po/templates/template.pot; git add .' >> ../.git/hooks/pre-commit
diff --git a/applications/luci-app-https_dns_proxy/root/etc/uci-defaults/40_luci-https_dns_proxy b/applications/luci-app-https_dns_proxy/root/etc/uci-defaults/40_luci-https_dns_proxy
new file mode 100644
index 000000000..7800af701
--- /dev/null
+++ b/applications/luci-app-https_dns_proxy/root/etc/uci-defaults/40_luci-https_dns_proxy
@@ -0,0 +1,10 @@
+#!/bin/sh
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@https_dns_proxy[-1]
+ add ucitrack https_dns_proxy
+ set ucitrack.@template[-1].init=https_dns_proxy
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0