diff options
-rw-r--r-- | luci.mk | 2 | ||||
-rw-r--r-- | modules/luci-base/Makefile | 2 |
2 files changed, 2 insertions, 2 deletions
@@ -153,7 +153,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci define SrcDiet $(FIND) $(1) -type f -name '*.lua' | while read src; do \ - if luasrcdiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \ + if LUA_PATH="$(STAGING_DIR_HOSTPKG)/lib/lua/5.1/?.lua" luasrcdiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \ then mv "$$$$src.o" "$$$$src"; fi; \ done endef diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile index 5c38d99c5..437cdc665 100644 --- a/modules/luci-base/Makefile +++ b/modules/luci-base/Makefile @@ -37,13 +37,13 @@ endef define Host/Compile $(MAKE) -C src/ clean po2lmo - $(MAKE) -C $(HOST_BUILD_DIR) bin/luasrcdiet endef define Host/Install $(INSTALL_DIR) $(1)/bin $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/luasrcdiet $(1)/bin/luasrcdiet + $(CP) $(HOST_BUILD_DIR)/luasrcdiet $(1)/lib/lua/5.1/ endef $(eval $(call HostBuild)) |