summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--contrib/package/luci/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 82c3ecfff..d55b60d14 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -87,6 +87,11 @@ define Package/luci/webtemplate
SUBMENU:=Components
endef
+define Package/luci/collectiontemplate
+ $(call Package/luci/libtemplate)
+ SUBMENU:=Collections
+endef
+
define Package/luci/install/template
$(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -959,6 +964,19 @@ define Package/luci-i18n-vietnamese/install
endef
+### Collections ###
+define Package/luci-kamikaze
+ $(call Package/luci/collectiontemplate)
+ TITLE:=Standard OpenWrt Kamikaze set including full and mini admin and the standard theme
+ DEPENDS:=+luci-admin-full +luci-admin-mini +luci-theme-openwrt +luci-app-firewall
+endef
+
+define Package/luci-light
+ $(call Package/luci/collectiontemplate)
+ TITLE:=Minimum package set using only admin mini and a theme without grafics
+ DEPENDS:=+luci-admin-mini +luci-theme-openwrtlight
+endef
+
### Compile ###
ifneq ($(CONFIG_PACKAGE_luci-core),)
PKG_SELECTED_MODULES+=libs/core
@@ -1267,3 +1285,6 @@ $(eval $(call BuildPackage,luci-i18n-catalan))
$(eval $(call BuildPackage,luci-i18n-portuguese))
$(eval $(call BuildPackage,luci-i18n-spanish))
$(eval $(call BuildPackage,luci-i18n-vietnamese))
+
+$(eval $(call BuildPackage,luci-kamikaze))
+$(eval $(call BuildPackage,luci-light))