summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--contrib/uci/Makefile1
-rw-r--r--libs/web/Makefile1
3 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 7dc9fa1e8..362eed69f 100644
--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,7 @@ i18nbuild:
clean:
rm -f .running-sdk
rm -rf docs
- make -C libs/lmo host-clean
+ make -C libs/web host-clean
for i in $(MODULES); do make -C$$i clean; done
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index b0ea8c0b6..d04c5a146 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -39,4 +39,5 @@ compile: $(UCI_DIR)/.prepared
compile-all: compile
clean:
+ rm -rf $(UCI_PATCHDIR)/series
rm -rf $(UCI_DIR) $(UCI_FILE)
diff --git a/libs/web/Makefile b/libs/web/Makefile
index 1d28a3a4c..ad16ec737 100644
--- a/libs/web/Makefile
+++ b/libs/web/Makefile
@@ -41,4 +41,5 @@ host-install: host-compile
cp src/$(TPL_PO2LMO) ../../build/$(TPL_PO2LMO)
host-clean:
+ rm -f src/$(TPL_PO2LMO)
rm -f ../../build/$(TPL_PO2LMO)