summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--contrib/package/luci-addons/Makefile2
-rw-r--r--contrib/package/luci/Makefile2
3 files changed, 4 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 362eed69f..b99e8f710 100644
--- a/Makefile
+++ b/Makefile
@@ -60,9 +60,6 @@ sdk:
ucidefaults:
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
-runhttpd: hostenv
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua build/lucid.lua"
-
runuhttpd: hostenv
cp $(realpath build)/luci.cgi $(realpath host)/www/cgi-bin/luci
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/usr/sbin/uhttpd -p 8080 -h $(realpath host)/www -f"
@@ -92,11 +89,8 @@ run:
# make run is deprecated #
# Please use: #
# #
- # To run LuCI WebUI using LuCIttpd #
- # make runhttpd #
- # #
- # To run LuCI WebUI using Boa/Webuci #
- # make runboa #
+ # To run LuCI WebUI using uhttpd #
+ # make runuhttpd #
# #
# To start a shell in the LuCI environment #
# make runshell #
diff --git a/contrib/package/luci-addons/Makefile b/contrib/package/luci-addons/Makefile
index c1c0992ce..c223054a2 100644
--- a/contrib/package/luci-addons/Makefile
+++ b/contrib/package/luci-addons/Makefile
@@ -262,7 +262,7 @@ define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(TAR) c -C $(LUCI_TOPDIR) . \
--exclude=.pc --exclude=.svn --exclude=.git \
- --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+ --exclude='*.o' --exclude='*.so' \
--exclude=dist | \
tar x -C $(PKG_BUILD_DIR)/
$(call Build/Prepare/Default)
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 5d81d436d..8bb35319b 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -423,7 +423,7 @@ define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(TAR) c -C $(LUCI_TOPDIR) . \
--exclude=.pc --exclude=.svn --exclude=.git \
- --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+ --exclude='*.o' --exclude='*.so' \
--exclude=dist | \
tar x -C $(PKG_BUILD_DIR)/
$(call Build/Prepare/Default)