summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rwxr-xr-xcontrib/package/ffluci/ipkg/ffluci.postinst2
2 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 317f3a666..e2a74c088 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ ffluci/fs.lua ffluci/i18n.lua ffluci/model/uci.lua \
ffluci/template.lua ffluci/cbi.lua ffluci/dispatcher.lua \
ffluci/menu.lua ffluci/init.lua ffluci/sys.lua
-DIRECTORIES = dist/ffluci/model dist/ffluci/controller/public dist/ffluci/controller/admin dist/ffluci/i18n dist/ffluci/view
+DIRECTORIES = dist/ffluci/model dist/ffluci/controller dist/ffluci/i18n dist/ffluci/view
INFILES = $(CFILES:%=src/%)
OUTFILE = ffluci/init.lua
@@ -25,8 +25,7 @@ examples-source: source examples
dist:
- cp src/ffluci/controller/public/* dist/ffluci/controller/public/
- cp src/ffluci/controller/admin/* dist/ffluci/controller/admin/
+ cp src/ffluci/controller/* dist/ffluci/controller/ -R
cp src/ffluci/i18n/* dist/ffluci/i18n/
cp src/ffluci/view/* dist/ffluci/view/ -R
diff --git a/contrib/package/ffluci/ipkg/ffluci.postinst b/contrib/package/ffluci/ipkg/ffluci.postinst
index 0dbac00eb..7265cb96b 100755
--- a/contrib/package/ffluci/ipkg/ffluci.postinst
+++ b/contrib/package/ffluci/ipkg/ffluci.postinst
@@ -1,4 +1,4 @@
#!/bin/sh
PATTERN='/cgi-bin/ffluci/admin:root:$p$root'
grep $PATTERN ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo $PATTERN >> ${IPKG_INSTROOT}/etc/httpd.conf
-[ -z ${IPKG_INSTROOT} ] && /etc/init.d/httpd restart
+[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart