summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-simple-adblock/Makefile5
-rw-r--r--applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua16
-rw-r--r--applications/luci-app-simple-adblock/po/templates/simple-adblock.pot6
3 files changed, 9 insertions, 18 deletions
diff --git a/applications/luci-app-simple-adblock/Makefile b/applications/luci-app-simple-adblock/Makefile
index d7be6850b..31055f120 100644
--- a/applications/luci-app-simple-adblock/Makefile
+++ b/applications/luci-app-simple-adblock/Makefile
@@ -7,9 +7,10 @@ PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=Simple Adblock Web UI
-LUCI_DEPENDS:=+simple-adblock
+LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
+LUCI_DEPENDS:=+luci +simple-adblock
LUCI_PKGARCH:=all
-PKG_RELEASE:=2
+PKG_RELEASE:=5
include ../../luci.mk
diff --git a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
index ff4638e9b..22672124f 100644
--- a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
+++ b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
@@ -2,19 +2,11 @@ m = Map("simple-adblock", translate("Simple AdBlock Settings"))
s = m:section(NamedSection, "config", "simple-adblock")
-- General options
-e = s:option(Flag, "enabled", translate("Enable/start service"))
+e = s:option(Flag, "enabled", translate("Start Simple Adblock service"))
e.rmempty = false
-
-function e.cfgvalue(self, section)
- return self.map:get(section, "enabled") == "1" and luci.sys.init.enabled("simple-adblock") and self.enabled or self.disabled
-end
-
function e.write(self, section, value)
- if value == "1" then
- luci.sys.call("/etc/init.d/simple-adblock enable >/dev/null")
- luci.sys.call("/etc/init.d/simple-adblock start >/dev/null")
- else
- luci.sys.call("/etc/init.d/simple-adblock stop >/dev/null")
+ if value ~= "1" then
+ luci.sys.init.stop("simple-adblock")
end
return Flag.write(self, section, value)
end
@@ -32,7 +24,6 @@ o3:value("1", translate("Force Router DNS server to all local devices"))
o3.rmempty = false
o3.default = 1
-
local sysfs_path = "/sys/class/leds/"
local leds = {}
if nixio.fs.access(sysfs_path) then
@@ -49,7 +40,6 @@ if #leds ~= 0 then
end
end
-
s2 = m:section(NamedSection, "config", "simple-adblock")
-- Whitelisted Domains
d1 = s2:option(DynamicList, "whitelist_domain", translate("Whitelisted Domains"), translate("Individual domains to be whitelisted"))
diff --git a/applications/luci-app-simple-adblock/po/templates/simple-adblock.pot b/applications/luci-app-simple-adblock/po/templates/simple-adblock.pot
index 4cfff964a..1a71cae62 100644
--- a/applications/luci-app-simple-adblock/po/templates/simple-adblock.pot
+++ b/applications/luci-app-simple-adblock/po/templates/simple-adblock.pot
@@ -13,9 +13,6 @@ msgstr ""
msgid "Controls system log and console output verbosity"
msgstr ""
-msgid "Enable/start service"
-msgstr ""
-
msgid "Force Router DNS"
msgstr ""
@@ -52,6 +49,9 @@ msgstr ""
msgid "Some output"
msgstr ""
+msgid "Start Simple Adblock service"
+msgstr ""
+
msgid "Suppress output"
msgstr ""