summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--contrib/package/luci/Makefile16
-rw-r--r--themes/base/Makefile2
-rw-r--r--themes/base/htdocs/luci-static/resources/Dropdowns.js (renamed from themes/openwrt.org/htdocs/luci-static/openwrt.org/Dropdowns.js)0
-rw-r--r--themes/base/htdocs/luci-static/resources/VarType.js (renamed from themes/openwrt.org/htdocs/luci-static/openwrt.org/VarType.js)0
-rw-r--r--themes/base/htdocs/luci-static/resources/XHTML1.js (renamed from themes/openwrt.org/htdocs/luci-static/openwrt.org/XHTML1.js)0
-rw-r--r--themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm6
6 files changed, 21 insertions, 3 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index da067fb4a..007c58d03 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -556,6 +556,16 @@ define Package/luci-sgi-webuci/install
endef
### Themes ###
+define Package/luci-theme-base
+ $(call Package/luci/thtemplate)
+ DEPENDS:=+luci-web
+ TITLE:=Common base for all themes
+endef
+
+define Package/luci-theme-base/install
+ $(call Package/luci/install/template,$(1),themes/base)
+endef
+
define Package/luci-theme-fledermaus
$(call Package/luci/fftemplate)
DEPENDS:=+luci-web
@@ -591,6 +601,7 @@ endef
define Package/luci-theme-openwrt
$(call Package/luci/thtemplate)
TITLE:=OpenWRT.org (default)
+ DEPENDS:=+luci-theme-base
endef
define Package/luci-theme-openwrt/install
@@ -600,6 +611,7 @@ endef
define Package/luci-theme-openwrtlight
$(call Package/luci/thtemplate)
TITLE:=OpenWRT.org - light variant without images
+ DEPENDS:=+luci-theme-base
endef
define Package/luci-theme-openwrtlight/install
@@ -777,6 +789,9 @@ ifneq ($(CONFIG_PACKAGE_luci-sgi-webuci),)
PKG_SELECTED_MODULES+=libs/sgi-webuci
endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-base),)
+ PKG_SELECTED_MODULES+=themes/base
+endif
ifneq ($(CONFIG_PACKAGE_luci-theme-fledermaus),)
PKG_SELECTED_MODULES+=themes/fledermaus
endif
@@ -862,6 +877,7 @@ $(eval $(call BuildPackage,luci-sgi-cgi))
$(eval $(call BuildPackage,luci-sgi-luci))
$(eval $(call BuildPackage,luci-sgi-webuci))
+$(eval $(call BuildPackage,luci-theme-base))
$(eval $(call BuildPackage,luci-theme-fledermaus))
$(eval $(call BuildPackage,luci-theme-freifunk))
$(eval $(call BuildPackage,luci-theme-freifunk-bno))
diff --git a/themes/base/Makefile b/themes/base/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/themes/base/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/themes/openwrt.org/htdocs/luci-static/openwrt.org/Dropdowns.js b/themes/base/htdocs/luci-static/resources/Dropdowns.js
index ff2f0e665..ff2f0e665 100644
--- a/themes/openwrt.org/htdocs/luci-static/openwrt.org/Dropdowns.js
+++ b/themes/base/htdocs/luci-static/resources/Dropdowns.js
diff --git a/themes/openwrt.org/htdocs/luci-static/openwrt.org/VarType.js b/themes/base/htdocs/luci-static/resources/VarType.js
index d4668109d..d4668109d 100644
--- a/themes/openwrt.org/htdocs/luci-static/openwrt.org/VarType.js
+++ b/themes/base/htdocs/luci-static/resources/VarType.js
diff --git a/themes/openwrt.org/htdocs/luci-static/openwrt.org/XHTML1.js b/themes/base/htdocs/luci-static/resources/XHTML1.js
index a7d4f7ddd..a7d4f7ddd 100644
--- a/themes/openwrt.org/htdocs/luci-static/openwrt.org/XHTML1.js
+++ b/themes/base/htdocs/luci-static/resources/XHTML1.js
diff --git a/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm b/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
index b2912b3a5..e658bfc67 100644
--- a/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
+++ b/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
@@ -46,9 +46,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen" href="<%=media%>/ie7.css" /><![endif]-->
<% if node and node.css then %><link rel="stylesheet" type="text/css" media="screen" href="<%=resource%>/<%=node.css%>" />
<% end -%>
-<script type="text/javascript" src="<%=media%>/VarType.js"></script>
-<script type="text/javascript" src="<%=media%>/XHTML1.js"></script>
-<script type="text/javascript" src="<%=media%>/Dropdowns.js"></script>
+<script type="text/javascript" src="<%=resource%>/VarType.js"></script>
+<script type="text/javascript" src="<%=resource%>/XHTML1.js"></script>
+<script type="text/javascript" src="<%=resource%>/Dropdowns.js"></script>
<title><%=striptags( hostname .. ( (node and node.title) and ' - ' .. node.title or '')) %> - LuCI</title>
</head>
<body class="lang_<%=luci.i18n.context.lang%>">