summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--contrib/package/uhttpd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/contrib/package/uhttpd/Makefile b/contrib/package/uhttpd/Makefile
index e2455ed26..ec37b2eab 100644
--- a/contrib/package/uhttpd/Makefile
+++ b/contrib/package/uhttpd/Makefile
@@ -27,14 +27,14 @@ define Package/uhttpd/description
HTTP daemon.
endef
+# hack to use CyASSL headers
+TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(CP) ./src/* $(PKG_BUILD_DIR)/
endef
-TARGET_CFLAGS += --std=c99 -D_POSIX_C_SOURCE=200112L -D_XOPEN_SOURCE=500
-TARGET_LDFLAGS += -lz -lm -lcrypt
-
define Package/uhttpd/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/sbin/