summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--CONTRIBUTING.md2
-rw-r--r--modules/luci-base/Makefile4
-rw-r--r--modules/luci-base/luasrc/cbi.lua2
-rw-r--r--modules/luci-base/root/etc/luci-uploads/.placeholder (renamed from modules/luci-base/root/lib/uci/upload/.placeholder)0
4 files changed, 6 insertions, 2 deletions
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index a392ade0c2..e4edf0c151 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -10,7 +10,7 @@ Regardless of whether you send a patch or open a pull request, please try to fol
* Have a useful subject prefixed with the component name
(E.g.: "luci-mod-admin-full: fix wifi channel selection on multiple STA networks")
* Shortly explain the changes made and - if applicable - the reasoning behind them
-* Include Signed-off-by in the comment
+* Commit message of each commit should include a Signed-off-by line
(See <https://dev.openwrt.org/wiki/SubmittingPatches#a10.Signyourwork>)
In case you like to send patches by mail, please use the [LuCI mailinglist](https://lists.subsignal.org/mailman/listinfo/luci)
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 26cbe0820e..a9c5e71cba 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -22,6 +22,10 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/LuaSrcDiet-0.12.1
include $(INCLUDE_DIR)/host-build.mk
+define Package/luci-base/conffiles
+/etc/luci-uploads
+endef
+
include ../../luci.mk
define Host/Configure
diff --git a/modules/luci-base/luasrc/cbi.lua b/modules/luci-base/luasrc/cbi.lua
index b5b2c8d8f2..8fd0a337e2 100644
--- a/modules/luci-base/luasrc/cbi.lua
+++ b/modules/luci-base/luasrc/cbi.lua
@@ -38,7 +38,7 @@ function load(cbimap, ...)
require("luci.config")
require("luci.util")
- local upldir = "/lib/uci/upload/"
+ local upldir = "/etc/luci-uploads/"
local cbidir = luci.util.libpath() .. "/model/cbi/"
local func, err
diff --git a/modules/luci-base/root/lib/uci/upload/.placeholder b/modules/luci-base/root/etc/luci-uploads/.placeholder
index e69de29bb2..e69de29bb2 100644
--- a/modules/luci-base/root/lib/uci/upload/.placeholder
+++ b/modules/luci-base/root/etc/luci-uploads/.placeholder