summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--collections/luci/Makefile2
-rw-r--r--luci.mk2
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua6
3 files changed, 5 insertions, 5 deletions
diff --git a/collections/luci/Makefile b/collections/luci/Makefile
index ace4735a0..4625c95f2 100644
--- a/collections/luci/Makefile
+++ b/collections/luci/Makefile
@@ -12,7 +12,7 @@ LUCI_BASENAME:=luci
LUCI_TITLE:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
LUCI_DEPENDS:= \
+uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
- +luci-app-firewall +luci-proto-ppp +libiwinfo-lua
+ +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6
include ../../luci.mk
diff --git a/luci.mk b/luci.mk
index ab09f0f4f..d77c09e22 100644
--- a/luci.mk
+++ b/luci.mk
@@ -182,7 +182,7 @@ define LuciTranslation
CATEGORY:=LuCI
TITLE:=$(PKG_NAME) - $(1) translation
HIDDEN:=1
- DEFAULT:=LUCI_LANG_$(1)||ALL
+ DEFAULT:=LUCI_LANG_$(1)||(ALL&&m)
DEPENDS:=$(PKG_NAME)
PKGARCH:=all
endef
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
index e3ae020f5..9315dc25b 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
@@ -69,21 +69,21 @@ nat = section:taboption("general", Flag, "nat",
translate("Behind NAT"),
translate("The tunnel end-point is behind NAT, defaults to disabled and only applies to AYIYA"))
nat.optional = true
-nat.default = disabled
+nat.default = nat.disabled
requiretls = section:taboption("general", Flag, "requiretls",
translate("Require TLS"),
translate("Connection to server fails when TLS cannot be used"))
requiretls.optional = true
-requiretls.default = requiretls.enabled
+requiretls.default = requiretls.disabled
verbose = section:taboption("advanced", Flag, "verbose",
translate("Verbose"),
translate("Verbose logging by aiccu daemon"))
verbose.optional = true
-verbose.default = disabled
+verbose.default = verbose.disabled
ntpsynctimeout = section:taboption("advanced", Value, "ntpsynctimeout",