summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--contrib/uci/Makefile5
-rw-r--r--libs/nixio/src/fs.c2
2 files changed, 2 insertions, 5 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 98e5ed439..19625aa72 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -23,12 +23,9 @@ $(UCI_FILE):
$(UCI_PATCHDIR)/series:
(cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
- while read patch; do \
- patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
- done < $(UCI_PATCHDIR)/series
touch $@
compile: $(UCI_DIR)/.prepared
diff --git a/libs/nixio/src/fs.c b/libs/nixio/src/fs.c
index e21623b85..53a406081 100644
--- a/libs/nixio/src/fs.c
+++ b/libs/nixio/src/fs.c
@@ -83,7 +83,7 @@ int nixio__check_mode(lua_State *L, int idx, int def) {
if (i == 9) { /* successfully parsed */
return mode;
}
- } else if (lua_isinteger(L, idx)) {
+ } else if (lua_isnumber(L, idx)) {
int decmode = lua_tointeger(L, idx);
int s = (decmode % 10000) / 1000;
int u = (decmode % 1000) / 100;