summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-dawn/Makefile2
-rw-r--r--applications/luci-app-dawn/luasrc/model/cbi/dawn/dawn_config.lua2
2 files changed, 2 insertions, 2 deletions
diff --git a/applications/luci-app-dawn/Makefile b/applications/luci-app-dawn/Makefile
index 330dddbf6c..1b2b598cc8 100644
--- a/applications/luci-app-dawn/Makefile
+++ b/applications/luci-app-dawn/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for DAWN
-LUCI_DEPENDS:=+dawn
+LUCI_DEPENDS:=+dawn +luci-compat +luci-lib-json
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-dawn/luasrc/model/cbi/dawn/dawn_config.lua b/applications/luci-app-dawn/luasrc/model/cbi/dawn/dawn_config.lua
index ab0c170f9c..b965451b03 100644
--- a/applications/luci-app-dawn/luasrc/model/cbi/dawn/dawn_config.lua
+++ b/applications/luci-app-dawn/luasrc/model/cbi/dawn/dawn_config.lua
@@ -11,7 +11,7 @@ s:option(Value, "chan_util", "Channel Utilization")
s:option(Value, "max_chan_util", "Above Maximum Channel Utilization")
s = m:section(TypedSection, "metric", "Threshold", "Thresholds"); s.anonymous = true;
-s:option(Value, "bandwith_threshold", "Bandwidth Threshold")
+s:option(Value, "bandwidth_threshold", "Bandwidth Threshold")
s:option(Value, "rssi_val", "RSSI Threshold")
s:option(Value, "low_rssi_val", "Low RSSI Threshold")
s:option(Value, "chan_util_val", "Channel Utilization Threshold")