summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua5
-rw-r--r--applications/luci-app-adblock/luasrc/view/adblock/runtime.htm14
-rw-r--r--applications/luci-app-radicale/Makefile4
-rw-r--r--applications/luci-app-travelmate/luasrc/controller/travelmate.lua2
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua3
-rw-r--r--applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm9
-rw-r--r--modules/luci-base/po/pl/base.po71
-rw-r--r--themes/luci-theme-bootstrap/htdocs/luci-static/bootstrap/cascade.css6
8 files changed, 58 insertions, 56 deletions
diff --git a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
index 3bf739291..2ecaaab72 100644
--- a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
+++ b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
@@ -3,7 +3,6 @@
local fs = require("nixio.fs")
local uci = require("luci.model.uci").cursor()
-local sys = require("luci.sys")
local util = require("luci.util")
local dump = util.ubus("network.interface", "dump", {})
@@ -13,10 +12,6 @@ m = Map("adblock", translate("Adblock"),
.. "<a href=\"%s\" target=\"_blank\">"
.. "check the online documentation</a>", "https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md"))
-function m.on_apply(self)
- luci.sys.call("/etc/init.d/adblock reload >/dev/null 2>&1")
-end
-
-- Main adblock options
s = m:section(NamedSection, "global", "adblock")
diff --git a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
index 05cdde73b..3f4d64259 100644
--- a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
+++ b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
@@ -6,7 +6,7 @@ This is free software, licensed under the Apache License, Version 2.0
<style type="text/css">
.runtime
{
- color: #0069d6;
+ color: #37c;
font-weight: bold;
display: inline-block;
width: 100%;
@@ -18,10 +18,12 @@ This is free software, licensed under the Apache License, Version 2.0
//<![CDATA[
function status_update(json)
{
- var view = document.getElementById("value_1");
- var btn1 = document.getElementById("btn1");
- var btn2 = document.getElementById("btn2");
- var input = json.data.adblock_status;
+ var view = document.getElementById("value_1");
+ var btn1 = document.getElementById("btn1");
+ var btn1_running = document.getElementById("btn1_running");
+ var btn2 = document.getElementById("btn2");
+ var btn2_running = document.getElementById("btn2_running");
+ var input = json.data.adblock_status;
view.innerHTML = input || "-";
if (input === "enabled")
@@ -126,7 +128,7 @@ This is free software, licensed under the Apache License, Version 2.0
btn2.value = "<%:Refresh%>";
btn2.name = "do_refresh";
btn1.disabled = true;
- btn2.disabled = false;
+ btn2.disabled = true;
return;
}
status_update(json_info)
diff --git a/applications/luci-app-radicale/Makefile b/applications/luci-app-radicale/Makefile
index 2b969ace5..87180e77d 100644
--- a/applications/luci-app-radicale/Makefile
+++ b/applications/luci-app-radicale/Makefile
@@ -14,10 +14,10 @@ PKG_VERSION:=1.1.0
# Release == build
# increase on changes of translation files
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
-PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
+PKG_MAINTAINER:=
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Radicale CardDAV/CalDAV
diff --git a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
index 00969ffe7..775831d9d 100644
--- a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
+++ b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
@@ -39,7 +39,7 @@ function trm_action(name)
if name == "do_restart" then
luci.sys.call("/etc/init.d/travelmate restart >/dev/null 2>&1")
end
- luci.http.prepare_content("text/plain")
+ luci.http.prepare_content("text/plain")
luci.http.write("0")
end
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
index ab39dab6b..a1a7ed72c 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
@@ -17,9 +17,10 @@ m = Map("travelmate", translate("Travelmate"),
.. "see online documentation</a>", "https://github.com/openwrt/packages/blob/master/net/travelmate/files/README.md"))
m:chain("network")
m:chain("firewall")
+m.apply_on_parse = true
function m.on_apply(self)
- luci.sys.call("env -i /etc/init.d/travelmate restart >/dev/null 2>&1")
+ luci.sys.call("/etc/init.d/travelmate restart >/dev/null 2>&1")
end
-- Interface Wizard
diff --git a/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm b/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
index aba4a3201..272612600 100644
--- a/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
+++ b/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
@@ -7,7 +7,6 @@ This is free software, licensed under the Apache License, Version 2.0
.runtime
{
color: #37c;
- //#0069d6;
font-weight: bold;
display: inline-block;
width: 100%;
@@ -22,7 +21,7 @@ This is free software, licensed under the Apache License, Version 2.0
var btn1 = document.getElementById("btn1");
var view = document.getElementById("value_1");
var input = json.data.travelmate_status;
-
+
btn1.value = "<%:Restart%>";
btn1.name = "do_restart";
view.innerHTML = input || "-";
@@ -41,8 +40,6 @@ This is free software, licensed under the Apache License, Version 2.0
view = document.getElementById("value_6");
input = json.data.last_rundate;
view.innerHTML = input || "-";
- btn1.disabled = false;
- running(btn1_running, 0);
}
function btn_action(action)
@@ -60,6 +57,8 @@ This is free software, licensed under the Apache License, Version 2.0
{
return;
}
+ btn1.disabled = false;
+ running(btn1_running, 0);
});
}
@@ -139,7 +138,7 @@ This is free software, licensed under the Apache License, Version 2.0
<div class="cbi-value" id="button_1">
<label class="cbi-value-title" for="button_1"><%:Restart Travelmate%></label>
<div class="cbi-value-field">
- <input class="cbi-button cbi-button-reset" id="btn1" type="button" value="" onclick="btn_action(this)" />
+ <input class="cbi-button cbi-button-reset" id="btn1" type="button" name="do_restart" value="<%:Restart%>" onclick="btn_action(this)" />
<span id="btn1_running" style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>
</div>
</div>
diff --git a/modules/luci-base/po/pl/base.po b/modules/luci-base/po/pl/base.po
index 61aee199b..d1b41e7c5 100644
--- a/modules/luci-base/po/pl/base.po
+++ b/modules/luci-base/po/pl/base.po
@@ -3,7 +3,7 @@ msgstr ""
"Project-Id-Version: LuCI\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2010-04-20 09:40+0200\n"
-"PO-Revision-Date: 2018-07-21 18:35+0200\n"
+"PO-Revision-Date: 2018-07-27 22:45+0200\n"
"Last-Translator: Rixerx <krystian.kozak20@gmail.com>\n"
"Language-Team: Polish\n"
"Language: pl\n"
@@ -210,11 +210,11 @@ msgid "ATM device number"
msgstr "Numer urządzenia ATM"
msgid "ATU-C System Vendor ID"
-msgstr ""
+msgstr "ID dostawcy systemu ATU-C"
# co to takiego?
msgid "Access Concentrator"
-msgstr "Koncentrator dostępowy ATM"
+msgstr "Koncentrator dostępowy (ATM)"
msgid "Access Point"
msgstr "Punkt dostępowy"
@@ -273,7 +273,7 @@ msgid "Advanced Settings"
msgstr "Ustawienia zaawansowane"
msgid "Aggregate Transmit Power(ACTATP)"
-msgstr ""
+msgstr "Agregacja siły transmisji (ACTATP)"
msgid "Alert"
msgstr "Alarm"
@@ -684,7 +684,7 @@ msgid ""
"Close inactive connection after the given amount of seconds, use 0 to "
"persist connection"
msgstr ""
-"Zamykaj nieaktywne połączenia po określonym czasie podanym w sekundach, "
+"Zamknij nieaktywne połączenia po określonym czasie podanym w sekundach, "
"wpisz 0 aby uzyskać stałe połączenie."
msgid "Close list..."
@@ -782,7 +782,7 @@ msgid "Custom Interface"
msgstr "Interfejs niestandardowy"
msgid "Custom delegated IPv6-prefix"
-msgstr ""
+msgstr "Delegowany niestandardowy prefiks IPv6"
msgid ""
"Custom feed definitions, e.g. private feeds. This file can be preserved in a "
@@ -864,7 +864,7 @@ msgid "DUID"
msgstr "DUID"
msgid "Data Rate"
-msgstr ""
+msgstr "Szybkość przesyłania danych"
msgid "Debug"
msgstr "Debug"
@@ -1198,7 +1198,7 @@ msgid "Error"
msgstr "Błąd"
msgid "Errored seconds (ES)"
-msgstr ""
+msgstr "Ilość błędów (ES)"
msgid "Ethernet Adapter"
msgstr "Karta Ethernet"
@@ -1357,7 +1357,7 @@ msgid "Forward DHCP traffic"
msgstr "Przekazuj ruch DHCP"
msgid "Forward Error Correction Seconds (FECS)"
-msgstr ""
+msgstr "Próby korekcji błędów (FECS)"
msgid "Forward broadcast traffic"
msgstr "Przekazuj broadcast`y"
@@ -1457,7 +1457,7 @@ msgid "Hang Up"
msgstr "Rozłącz"
msgid "Header Error Code Errors (HEC)"
-msgstr ""
+msgstr "Błędy kodu nagłówka (HEC)"
msgid ""
"Here you can configure the basic aspects of your device like its hostname or "
@@ -1812,7 +1812,7 @@ msgid "LCP echo failure threshold"
msgstr "Próg błędu echa LCP"
msgid "LCP echo interval"
-msgstr "Częstotliwość echa LCP"
+msgstr "Interwał echa LCP"
msgid "LLC"
msgstr "LLC"
@@ -1845,10 +1845,10 @@ msgid "Leasetime remaining"
msgstr "Pozostały czas dzierżawy"
msgid "Leave empty to autodetect"
-msgstr "Pozostaw niewypełnione dla autodetekcji"
+msgstr "Pozostaw puste, aby automatycznie wykryć"
msgid "Leave empty to use the current WAN address"
-msgstr "Pozostaw niewypełnione aby użyć bieżącego adresu WAN"
+msgstr "Pozostaw puste, aby użyć bieżącego adresu WAN"
msgid "Legend:"
msgstr "Legenda:"
@@ -1864,16 +1864,16 @@ msgid "Limit listening to these interfaces, and loopback."
msgstr "Ogranicz nasłuchiwanie do tych interfesjów, oraz loopbacku."
msgid "Line Attenuation (LATN)"
-msgstr ""
+msgstr "Tłumienie linii (LATN)"
msgid "Line Mode"
-msgstr ""
+msgstr "Tryb linii"
msgid "Line State"
-msgstr ""
+msgstr "Stan linii"
msgid "Line Uptime"
-msgstr ""
+msgstr "Czas działania linii"
msgid "Link On"
msgstr "Połączenie aktywne"
@@ -2000,7 +2000,7 @@ msgid "Logout"
msgstr "Wyloguj"
msgid "Loss of Signal Seconds (LOSS)"
-msgstr ""
+msgstr "Utrata sygnału (LOSS)"
msgid "Lowest leased address as offset from the network address."
msgstr "Najniższy wydzierżawiony adres jako offset dla adresu sieci."
@@ -2049,7 +2049,7 @@ msgid "Manual"
msgstr ""
msgid "Max. Attainable Data Rate (ATTNDR)"
-msgstr ""
+msgstr "Max. Osiągalna szybkość transmisji danych (ATTNDR)"
msgid "Maximum allowed number of active DHCP leases"
msgstr "Maksymalna dozwolona liczba aktywnych dzierżaw DHCP"
@@ -2268,7 +2268,7 @@ msgid "Noise:"
msgstr "Szum:"
msgid "Non Pre-emtive CRC errors (CRC_P)"
-msgstr ""
+msgstr "Nieprzewidziane błedy CRC (CRC_P)"
msgid "Non-wildcard"
msgstr "Bez symboli wieloznacznych"
@@ -2318,7 +2318,7 @@ msgid "Obfuscated Password"
msgstr ""
msgid "Obtain IPv6-Address"
-msgstr ""
+msgstr "Uzyskaj adres IPv6"
msgid "Off-State Delay"
msgstr "Zwłoka wyłączenia"
@@ -2613,7 +2613,7 @@ msgid "Power Management Mode"
msgstr "Tryb zarządzania energią"
msgid "Pre-emtive CRC errors (CRCP_P)"
-msgstr ""
+msgstr "Przewidziane błedy CRC (CRCP_P)"
msgid "Prefer LTE"
msgstr ""
@@ -2631,8 +2631,8 @@ msgid ""
"Presume peer to be dead after given amount of LCP echo failures, use 0 to "
"ignore failures"
msgstr ""
-"Zakładaj że klient jest martwy po danej ilości błedów odpowiedzi echa LCP, "
-"wpisz 0 aby zignorować błędy"
+"Przypuszczaj że klient może być martwy po zadanej ilości błedów echa LCP, "
+"wpisz 0 aby zignorować te błędy"
msgid "Prevent listening on these interfaces."
msgstr "Zapobiegaj nasłuchiwaniu na tych interfejsach."
@@ -2840,7 +2840,7 @@ msgid "Request IPv6-address"
msgstr "Zażądaj adresu IPv6"
msgid "Request IPv6-prefix of length"
-msgstr ""
+msgstr "Zażądaj długość prefiksu IPv6"
msgid "Required"
msgstr "Wymagany"
@@ -3007,8 +3007,8 @@ msgid ""
"Send LCP echo requests at the given interval in seconds, only effective in "
"conjunction with failure threshold"
msgstr ""
-"Co podany czas (w sekundach) wyślij zapytania LCP echo, to ustawienie działa "
-"tylko gdy ustawiony jest próg błędu LCP echo"
+"Wysyłaj żądania echa LCP w określonym przedziale czasowym, "
+"efektywne tylko wtedy gdy jest ustawiony próg błedu LCP"
msgid "Separate Clients"
msgstr "Rozdziel klientów"
@@ -3046,7 +3046,7 @@ msgid "Setup DHCP Server"
msgstr "Ustawienia serwera DHCP"
msgid "Severely Errored Seconds (SES)"
-msgstr ""
+msgstr "Ilość poważnych błedów (SES)"
msgid "Short GI"
msgstr ""
@@ -3064,7 +3064,7 @@ msgid "Signal"
msgstr "Sygnał"
msgid "Signal Attenuation (SATN)"
-msgstr ""
+msgstr "Tłumienie sygnału (SATN)"
msgid "Signal:"
msgstr "Sygnał:"
@@ -3159,7 +3159,7 @@ msgid "Start priority"
msgstr "Priorytet uruchomienia"
msgid "Starting configuration apply…"
-msgstr ""
+msgstr "Zatwierdzanie konfiguracji…"
msgid "Starting wireless scan..."
msgstr "Rozpoczynanie skanowania..."
@@ -3193,7 +3193,7 @@ msgstr ""
"odpowiednim dzierżawami."
msgid "Status"
-msgstr "Stan"
+msgstr "Status"
msgid "Stop"
msgstr "Stop"
@@ -3365,10 +3365,9 @@ msgid ""
"compare them with the original file to ensure data integrity.<br /> Click "
"\"Proceed\" below to start the flash procedure."
msgstr ""
-"Obraz flash`a został przesłany. Poniżej znajduje się suma kontrolna i "
-"rozmiar obrazu, porównaj je z sumą kontrolną i rozmiarem oryginału, aby "
-"upewnić się, że został przesłany poprawnie.<br /> Wciśnij \"Wykonaj\" aby "
-"kontynuować aktualizację."
+"Obraz flash został przesłany. Poniżej znajduje się suma kontrolna i "
+"rozmiar pliku, porównaj je z orginałem aby zapewnić integralność "
+"danych.<br /> Wciśnij \"Wykonaj\" aby kontynuować aktualizację."
msgid "The following changes have been reverted"
msgstr "Następujące zmiany zostały odrzucone"
@@ -3656,7 +3655,7 @@ msgid "Unable to resolve peer host name"
msgstr "Nie można rozpoznać nazwy peera"
msgid "Unavailable Seconds (UAS)"
-msgstr ""
+msgstr "Czas niedostępnośći (UAS)"
msgid "Unknown"
msgstr "Nieznany"
diff --git a/themes/luci-theme-bootstrap/htdocs/luci-static/bootstrap/cascade.css b/themes/luci-theme-bootstrap/htdocs/luci-static/bootstrap/cascade.css
index 0c158961d..e34b0b594 100644
--- a/themes/luci-theme-bootstrap/htdocs/luci-static/bootstrap/cascade.css
+++ b/themes/luci-theme-bootstrap/htdocs/luci-static/bootstrap/cascade.css
@@ -598,6 +598,12 @@ textarea[readonly] {
cursor: default;
}
+select[readonly],
+textarea[readonly] {
+ pointer-events: auto;
+ cursor: auto;
+}
+
.cbi-optionals,
.cbi-section-create {
padding: 0 0 10px 10px;