summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--build/gccconfig.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
index 0e4de2795..77bcf3674 100644
--- a/build/gccconfig.mk
+++ b/build/gccconfig.mk
@@ -1,22 +1,22 @@
OS ?= $(shell uname)
-LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1)
-LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
-LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1)
+LUA_SHLIBS ?= $(shell pkg-config --silence-errors --libs lua5.1)
+LUA_LIBS ?= $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
+LUA_CFLAGS ?= $(shell pkg-config --silence-errors --cflags lua5.1)
-CC = gcc
-AR = ar
-RANLIB = ranlib
-CFLAGS = -O2
-FPIC = -fPIC
-EXTRA_CFLAGS = --std=gnu99
-WFLAGS = -Wall -Werror -pedantic
-CPPFLAGS =
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
+CC ?= gcc
+AR ?= ar
+RANLIB ?= ranlib
+CFLAGS ?= -O2
+FPIC ?= -fPIC
+EXTRA_CFLAGS ?= --std=gnu99
+WFLAGS ?= -Wall -Werror -pedantic
+CPPFLAGS ?=
+COMPILE ?= $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
ifeq ($(OS),Darwin)
- SHLIB_FLAGS = -bundle -undefined dynamic_lookup
+ SHLIB_FLAGS ?= -bundle -undefined dynamic_lookup
else
- SHLIB_FLAGS = -shared
+ SHLIB_FLAGS ?= -shared
endif
-LINK = $(CC)
+LINK ?= $(CC)