diff options
-rw-r--r-- | luci.mk | 2 | ||||
-rw-r--r-- | modules/luci-base/Makefile | 3 |
2 files changed, 3 insertions, 2 deletions
@@ -150,7 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci define SrcDiet $(FIND) $(1) -type f -name '*.lua' | while read src; do \ - if $(STAGING_DIR_HOST)/bin/lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet \ + if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \ --noopt-binequiv -o "$$$$src.o" "$$$$src"; \ then mv "$$$$src.o" "$$$$src"; fi; \ done diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile index a9c5e71cb..f0763cb1d 100644 --- a/modules/luci-base/Makefile +++ b/modules/luci-base/Makefile @@ -37,9 +37,10 @@ define Host/Compile endef define Host/Install + $(INSTALL_DIR) $(STAGING_DIR)/host/bin $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo - $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet + $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet endef $(eval $(call HostBuild)) |