summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--]applications/luci-splash/root/etc/cron.minutely/luci_splash0
-rwxr-xr-x[-rw-r--r--]applications/luci-splash/root/etc/init.d/luci_splash0
-rwxr-xr-x[-rw-r--r--]applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi15
-rwxr-xr-x[-rw-r--r--]applications/luci-splash/root/usr/sbin/luci-splash0
-rwxr-xr-x[-rw-r--r--]applications/luci-splash/root/www/cgi-bin/luci-splash0
-rw-r--r--contrib/package/luci/Makefile7
6 files changed, 9 insertions, 13 deletions
diff --git a/applications/luci-splash/root/etc/cron.minutely/luci_splash b/applications/luci-splash/root/etc/cron.minutely/luci_splash
index eae429474..eae429474 100644..100755
--- a/applications/luci-splash/root/etc/cron.minutely/luci_splash
+++ b/applications/luci-splash/root/etc/cron.minutely/luci_splash
diff --git a/applications/luci-splash/root/etc/init.d/luci_splash b/applications/luci-splash/root/etc/init.d/luci_splash
index 20f7865fd..20f7865fd 100644..100755
--- a/applications/luci-splash/root/etc/init.d/luci_splash
+++ b/applications/luci-splash/root/etc/init.d/luci_splash
diff --git a/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi b/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
index 22cab67cc..29679a21c 100644..100755
--- a/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
+++ b/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
@@ -1,6 +1,5 @@
-#!/usr/bin/haserl --shell=luac
+#!/usr/bin/lua
-require("luci.http")
require("luci.sys")
require("luci.model.uci")
@@ -8,7 +7,7 @@ luci.model.uci.set_savedir(luci.model.uci.savedir_state)
local srv
local net
-local ip = luci.http.env.REMOTE_ADDR
+local ip = os.getenv("REMOTE_ADDR")
luci.model.uci.foreach("network", "interface",
function (section)
if section.ipaddr then
@@ -30,10 +29,11 @@ luci.model.uci.foreach("luci_splash", "iface",
end)
if not srv then
- luci.http.prepare_content("text/plain")
+ print("Content-Type: text/plain\n")
print("Unable to detect network settings!")
elseif not stat then
- luci.http.redirect("http://" .. srv)
+ print("Status: 302 Found")
+ print("Location: http://" .. srv)
else
local action = "splash"
@@ -48,5 +48,6 @@ else
action = "allowed"
end
- luci.http.redirect("http://" .. srv .. "/cgi-bin/luci-splash/" .. action)
-end \ No newline at end of file
+ print("Status: 302 Found")
+ print("Location: http://" .. srv .. "/cgi-bin/luci-splash/" .. action)
+end
diff --git a/applications/luci-splash/root/usr/sbin/luci-splash b/applications/luci-splash/root/usr/sbin/luci-splash
index 72456c01e..72456c01e 100644..100755
--- a/applications/luci-splash/root/usr/sbin/luci-splash
+++ b/applications/luci-splash/root/usr/sbin/luci-splash
diff --git a/applications/luci-splash/root/www/cgi-bin/luci-splash b/applications/luci-splash/root/www/cgi-bin/luci-splash
index c75593fbe..c75593fbe 100644..100755
--- a/applications/luci-splash/root/www/cgi-bin/luci-splash
+++ b/applications/luci-splash/root/www/cgi-bin/luci-splash
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 7557c827e..af662f8cb 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -282,7 +282,7 @@ endef
define Package/luci-app-splash
$(call Package/luci/fftemplate)
- DEPENDS+=+luci-sgi-haserl +iptables-mod-nat +iptables-mod-ipopt
+ DEPENDS+=+iptables-mod-nat +iptables-mod-ipopt
TITLE:=Freifunk DHCP-Splash application
endef
@@ -292,11 +292,6 @@ endef
define Package/luci-app-splash/install
$(call Package/luci/install/template,$(1),applications/luci-splash)
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/sbin/luci-splash $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/init.d/luci_splash $(1)/etc/init.d
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/cron.minutely/luci_splash $(1)/etc/cron.minutely
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi $(1)/usr/lib/luci-splash/htdocs/cgi-bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/www/cgi-bin/luci-splash $(1)/www/cgi-bin/luci-splash
endef