summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-unbound/root/etc/uci-defaults/60_luci-unbound25
-rw-r--r--applications/luci-app-vpnbypass/Makefile2
-rw-r--r--applications/luci-app-vpnbypass/luasrc/controller/vpnbypass.lua3
3 files changed, 26 insertions, 4 deletions
diff --git a/applications/luci-app-unbound/root/etc/uci-defaults/60_luci-unbound b/applications/luci-app-unbound/root/etc/uci-defaults/60_luci-unbound
new file mode 100644
index 0000000000..cc714ac53e
--- /dev/null
+++ b/applications/luci-app-unbound/root/etc/uci-defaults/60_luci-unbound
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@unbound[-1]
+ add ucitrack unbound
+ set ucitrack.@unbound[-1].init=unbound
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+[ ! -x /usr/sbin/unbound-control ] && exit 0
+
+uci -q batch <<-EOF >/dev/null
+ set luci.unboundhosts=command
+ set luci.unboundhosts.name='Unbound Local Hosts'
+ set luci.unboundhosts.command='unbound-control -c /var/lib/unbound/unbound.conf list_local_data'
+ set luci.unboundzones=command
+ set luci.unboundzones.name='Unbound Local Zones'
+ set luci.unboundzones.command='unbound-control -c /var/lib/unbound/unbound.conf list_local_zones'
+ commit luci
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0
+
diff --git a/applications/luci-app-vpnbypass/Makefile b/applications/luci-app-vpnbypass/Makefile
index 5f63dcee7e..e26fe273cc 100644
--- a/applications/luci-app-vpnbypass/Makefile
+++ b/applications/luci-app-vpnbypass/Makefile
@@ -3,8 +3,6 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=1.0.0
-PKG_RELEASE:=5
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
diff --git a/applications/luci-app-vpnbypass/luasrc/controller/vpnbypass.lua b/applications/luci-app-vpnbypass/luasrc/controller/vpnbypass.lua
index 6becd67914..ed6f4f4da4 100644
--- a/applications/luci-app-vpnbypass/luasrc/controller/vpnbypass.lua
+++ b/applications/luci-app-vpnbypass/luasrc/controller/vpnbypass.lua
@@ -3,6 +3,5 @@ function index()
if not nixio.fs.access("/etc/config/vpnbypass") then
return
end
- entry({"admin", "services", "vpnbypass"}, cbi("vpnbypass"), translate("VPN Bypass"), 1)
+ entry({"admin", "services", "vpnbypass"}, cbi("vpnbypass"), _("VPN Bypass"))
end
-