summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--luci.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/luci.mk b/luci.mk
index 26f3c94f90..137886f1b3 100644
--- a/luci.mk
+++ b/luci.mk
@@ -70,9 +70,8 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \
PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \
variant="LuCI"; \
if git log -1 >/dev/null 2>/dev/null; then \
- branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null || \
- git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \
- sed -e 's|^.*/||; s| .*||; q')"; \
+ branch="$$(git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \
+ sed -rne 's|^[^/]+/([^ ]+) [a-f0-9]{40} .+$$|\1|p' | head -n1)"; \
if [ "$$branch" != "master" ]; then \
variant="LuCI $$branch branch"; \
else \