summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--luci.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/luci.mk b/luci.mk
index 621008aa87..0b3a66e3b5 100644
--- a/luci.mk
+++ b/luci.mk
@@ -65,9 +65,13 @@ define findrev
$(shell \
if git log -1 >/dev/null 2>/dev/null; then \
set -- $$(git log -1 --format="%ct %h" --abbrev=7 -- '$(if $(1),:(exclude))po'); \
- secs="$$(($$1 % 86400))"; \
- yday="$$(date --utc --date="@$$1" "+%y.%j")"; \
- printf 'git-%s.%05d-%s' "$$yday" "$$secs" "$$2"; \
+ if [ -n "$$1" ]; then
+ secs="$$(($$1 % 86400))"; \
+ yday="$$(date --utc --date="@$$1" "+%y.%j")"; \
+ printf 'git-%s.%05d-%s' "$$yday" "$$secs" "$$2"; \
+ else \
+ echo "unknown"; \
+ fi; \
else \
ts=$$(find . -type f $(if $(1),-not) -path './po/*' -printf '%T@\n' 2>/dev/null | sort -rn | head -n1 | cut -d. -f1); \
if [ -n "$$ts" ]; then \