summaryrefslogtreecommitdiffhomepage
path: root/themes/luci-theme-openwrt/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2023-01-09 13:44:38 +0100
committerGitHub <noreply@github.com>2023-01-09 13:44:38 +0100
commit41991f8d2ade0aea0a1b1090de7cbb31f6ae3299 (patch)
tree27f2b462564e4279a4e09a4e7de19227eda9a587 /themes/luci-theme-openwrt/Makefile
parent8991355c337ec3532d543f73b52f7f261d03a157 (diff)
parent21b40652d9b40210075ae1b00a548520a211c862 (diff)
Merge pull request #6191 from TDT-AG/pr/20230109-luci-theme
luci-theme-: add postrm script
Diffstat (limited to 'themes/luci-theme-openwrt/Makefile')
-rw-r--r--themes/luci-theme-openwrt/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/themes/luci-theme-openwrt/Makefile b/themes/luci-theme-openwrt/Makefile
index b873d80727..41f479157c 100644
--- a/themes/luci-theme-openwrt/Makefile
+++ b/themes/luci-theme-openwrt/Makefile
@@ -9,6 +9,14 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI OpenWrt.org theme
LUCI_DEPENDS:=
+define Package/luci-theme-openwrt/postrm
+#!/bin/sh
+[ -n "$${IPKG_INSTROOT}" ] || {
+ uci -q delete luci.themes.OpenWrt
+ uci commit luci
+}
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature