summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
authorNicholas Smith <nicholas.smith@telcoantennas.com.au>2019-10-09 09:51:20 +1000
committerNicholas Smith <nicholas.smith@telcoantennas.com.au>2019-10-11 08:27:02 +1000
commit6a79c61221132f170b8cfec7d01010f39bfe8a1e (patch)
tree0a1972d2087a133b622cfedec524f6f0d56c8942 /protocols
parenta1545331219ed608eb6625ce5d38fa216f5bfdc8 (diff)
luci-proto-modemmanager: add luci-proto-modemmanager
Signed-off-by: Nicholas Smith <nicholas.smith@telcoantennas.com.au>
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-modemmanager/Makefile14
-rw-r--r--protocols/luci-proto-modemmanager/htdocs/luci-static/resources/protocol/modemmanager.js101
-rw-r--r--protocols/luci-proto-modemmanager/luasrc/model/network/proto_modemmanager.lua55
3 files changed, 170 insertions, 0 deletions
diff --git a/protocols/luci-proto-modemmanager/Makefile b/protocols/luci-proto-modemmanager/Makefile
new file mode 100644
index 000000000..c2718dd0a
--- /dev/null
+++ b/protocols/luci-proto-modemmanager/Makefile
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for ModemManager
+LUCI_DEPENDS:=+modemmanager
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-modemmanager/htdocs/luci-static/resources/protocol/modemmanager.js b/protocols/luci-proto-modemmanager/htdocs/luci-static/resources/protocol/modemmanager.js
new file mode 100644
index 000000000..ae68bfd8f
--- /dev/null
+++ b/protocols/luci-proto-modemmanager/htdocs/luci-static/resources/protocol/modemmanager.js
@@ -0,0 +1,101 @@
+'use strict';
+'require rpc';
+'require form';
+'require network';
+
+var callFileList = rpc.declare({
+ object: 'file',
+ method: 'list',
+ params: [ 'path' ],
+ expect: { entries: [] },
+ filter: function(list, params) {
+ var rv = [];
+ for (var i = 0; i < list.length; i++)
+ if (list[i].name.match(/^cdc-wdm/))
+ rv.push(params.path + list[i].name);
+ return rv.sort();
+ }
+});
+
+network.registerPatternVirtual(/^mobiledata-.+$/);
+network.registerErrorCode('CALL_FAILED', _('Call failed'));
+network.registerErrorCode('NO_CID', _('Unable to obtain client ID'));
+network.registerErrorCode('PLMN_FAILED', _('Setting PLMN failed'));
+
+return network.registerProtocol('modemmanager', {
+ getI18n: function() {
+ return _('ModemManager');
+ },
+
+ getIfname: function() {
+ return this._ubus('l3_device') || 'modemmanager-%s'.format(this.sid);
+ },
+
+ getOpkgPackage: function() {
+ return 'modemmanager';
+ },
+
+ isFloating: function() {
+ return true;
+ },
+
+ isVirtual: function() {
+ return true;
+ },
+
+ getDevices: function() {
+ return null;
+ },
+
+ containsDevice: function(ifname) {
+ return (network.getIfnameOf(ifname) == this.getIfname());
+ },
+
+ renderFormOptions: function(s) {
+ var dev = this.getL3Device() || this.getDevice(), o;
+
+ o = s.taboption('general', form.ListValue, 'device', _('Modem device'));
+ o.rmempty = false;
+ o.load = function(section_id) {
+ return callFileList('/dev/').then(L.bind(function(devices) {
+ for (var i = 0; i < devices.length; i++)
+ this.value(devices[i]);
+ return form.Value.prototype.load.apply(this, [section_id]);
+ }, this));
+ };
+
+ s.taboption('general', form.Value, 'apn', _('APN'));
+ s.taboption('general', form.Value, 'pincode', _('PIN'));
+
+ o = s.taboption('general', form.ListValue, 'auth', _('Authentication Type'));
+ o.value('both', 'PAP/CHAP (both)');
+ o.value('pap', 'PAP');
+ o.value('chap', 'CHAP');
+ o.value('none', 'NONE');
+ o.default = 'none';
+
+ o = s.taboption('general', form.Value, 'username', _('PAP/CHAP username'));
+ o.depends('auth', 'pap');
+ o.depends('auth', 'chap');
+ o.depends('auth', 'both');
+
+ o = s.taboption('general', form.Value, 'password', _('PAP/CHAP password'));
+ o.depends('auth', 'pap');
+ o.depends('auth', 'chap');
+ o.depends('auth', 'both');
+ o.password = true;
+
+ o = s.taboption('general', form.ListValue, 'iptype', _('IP Type'));
+ o.value('ipv4v6', 'IPv4 IPv6 (both - defaults to IPv4)')
+ o.value('ipv4', 'IPv4 only');
+ o.value('ipv6', 'IPv6 only');
+ o.default = 'ipv4v6';
+
+ o = s.taboption('advanced', form.Value, 'mtu', _('Override MTU'));
+ o.placeholder = dev ? (dev.getMTU() || '1500') : '1500';
+ o.datatype = 'max(9200)';
+
+ s.taboption('general', form.Value, 'metric', _('Gateway metric'));
+
+ }
+});
diff --git a/protocols/luci-proto-modemmanager/luasrc/model/network/proto_modemmanager.lua b/protocols/luci-proto-modemmanager/luasrc/model/network/proto_modemmanager.lua
new file mode 100644
index 000000000..3ad15dfd2
--- /dev/null
+++ b/protocols/luci-proto-modemmanager/luasrc/model/network/proto_modemmanager.lua
@@ -0,0 +1,55 @@
+-- Copyright 2016 David Thornley <david.thornley@touchstargroup.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local netmod = luci.model.network
+local interface = luci.model.network.interface
+local proto = netmod:register_protocol("modemmanager")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("Mobile Data")
+end
+
+function proto.ifname(self)
+ local base = netmod._M.protocol
+ local ifname = base.ifname(self) -- call base class "protocol.ifname(self)"
+
+ -- Note: ifname might be nil if the adapter could not be determined through ubus (default name to qmi-wan in this case)
+ if ifname == nil then
+ ifname = "modemmanager-" .. self.sid
+ end
+ return ifname
+end
+
+function proto.get_interface(self)
+ return interface(self:ifname(), self)
+end
+
+function proto.opkg_package(self)
+ return "modemmanager"
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/modemmanager.sh")
+end
+
+function proto.is_floating(self)
+ return true
+end
+
+function proto.is_virtual(self)
+ return true
+end
+
+function proto.get_interfaces(self)
+ return nil
+end
+
+function proto.contains_interface(self, ifc)
+ return (netmod:ifnameof(ifc) == self:ifname())
+end
+
+netmod:register_pattern_virtual("^mobiledata%-%w")
+
+netmod:register_error_code("CALL_FAILED", luci.i18n.translate("Call failed"))
+netmod:register_error_code("NO_CID", luci.i18n.translate("Unable to obtain client ID"))
+netmod:register_error_code("PLMN_FAILED", luci.i18n.translate("Setting PLMN failed"))