summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-10-04 11:27:31 +0300
committerGitHub <noreply@github.com>2016-10-04 11:27:31 +0300
commite3287d84e107c4316fbf770a21b3088bc623beb5 (patch)
tree7ee5b5e5ff28008a3e80deae974faa329792f238 /modules
parent4a246820b1d12e8aed5b443d9f57da57ac3bc27b (diff)
parentf7639bcd6a2caf7cc0f03e85744906c577eefeab (diff)
Merge pull request #813 from NeoRaider/staging-dir-host
luci-base: fix luci-base host tool install on OpenWrt
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 972a451c6..4fb278b56 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,9 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(HOST_BUILD_PREFIX)/bin
+ $(INSTALL_BIN) src/po2lmo $(HOST_BUILD_PREFIX)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(HOST_BUILD_PREFIX)/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))