summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-03-10 19:50:58 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2016-03-10 19:50:58 +0200
commit7553654bb10af9206cff9837a485b828d1998213 (patch)
treea624ec0aa1e192841c8752b534efd92b9586a3c9 /modules
parentac9b31ca462b5662e98a0ac6b57fb49c4c4e32de (diff)
LuCI: Display the proper LuCI git branch in GUI
Adjust luci.mk and luci-base to find out correctly if Luci is built from master or from a branch. Display that value in the footer and the overview page. * Evaluate the git branch in luci.mk and pass that to LuCI submodules as a make variable. Use branch name, ignore tags. * Deprecate svn detection in luci-base's mkversion.sh that generates version.lua. Simply use the value passed by make. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/src/Makefile2
-rwxr-xr-xmodules/luci-base/src/mkversion.sh25
2 files changed, 2 insertions, 25 deletions
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
index 7bb7f2ebe..03e887e1d 100644
--- a/modules/luci-base/src/Makefile
+++ b/modules/luci-base/src/Makefile
@@ -11,7 +11,7 @@ parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o
$(CC) $(LDFLAGS) -shared -o $@ $^
version.lua:
- ./mkversion.sh $@ $(LUCI_VERSION)
+ ./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)"
compile: parser.so version.lua
diff --git a/modules/luci-base/src/mkversion.sh b/modules/luci-base/src/mkversion.sh
index 55b0ebd22..33c7a3ffe 100755
--- a/modules/luci-base/src/mkversion.sh
+++ b/modules/luci-base/src/mkversion.sh
@@ -1,28 +1,5 @@
#!/bin/sh
-if svn info >/dev/null 2>/dev/null; then
- if [ "${4%%/*}" = "branches" ]; then
- variant="LuCI ${4##*[-/]} Branch"
- elif [ "${4%%/*}" = "tags" ]; then
- variant="LuCI ${4##*[-/]} Release"
- else
- variant="LuCI Trunk"
- fi
-elif git status >/dev/null 2>/dev/null; then
- tag="$(git describe --tags 2>/dev/null)"
- branch="$(git symbolic-ref --short -q HEAD 2>/dev/null)"
-
- if [ -n "$tag" ]; then
- variant="LuCI $tag Release"
- elif [ "$branch" != "master" ]; then
- variant="LuCI ${branch##*-} Branch"
- else
- variant="LuCI Master"
- fi
-else
- variant="LuCI"
-fi
-
cat <<EOF > $1
local pcall, dofile, _G = pcall, dofile, _G
@@ -36,6 +13,6 @@ else
distversion = "Development Snapshot"
end
-luciname = "$variant"
+luciname = "${3:-LuCI}"
luciversion = "${2:-Git}"
EOF