summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-13 21:10:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-13 21:10:18 +0000
commit785f71ebaf33052e04128c1beca4125bf576cca5 (patch)
tree4f09ed5dd5791dcd01d1968a77040c595c76896e /modules
parentfab386913f5cff028d1d92b6573757d0d1f576f6 (diff)
modules/admin-full: reorder compiler flags for luci-bwc, fixes build on Ubuntu 11.x
Diffstat (limited to 'modules')
-rw-r--r--modules/admin-full/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/admin-full/Makefile b/modules/admin-full/Makefile
index 77335c399..819d13f33 100644
--- a/modules/admin-full/Makefile
+++ b/modules/admin-full/Makefile
@@ -11,7 +11,7 @@ BWC_OBJ = src/luci-bwc.o
$(COMPILE) $(BWC_CFLAGS) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
compile: build-clean $(BWC_OBJ)
- $(LINK) $(BWC_LDFLAGS) -o src/$(BWC_BIN) $(BWC_OBJ)
+ $(LINK) -o src/$(BWC_BIN) $(BWC_OBJ) $(BWC_LDFLAGS)
mkdir -p dist/usr/bin
cp src/$(BWC_BIN) dist/usr/bin/$(BWC_BIN)