summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:43:57 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:44:15 +0200
commit4d97a9f6986fb37ce7e69a1ca3f4743334495654 (patch)
treeed787f20036e88d54c8378981b2f40622ff6f0af /modules
parente06c60a0d669bed72e495d51f5e30513b05f5605 (diff)
luci-base: use default install paths for host utils
This reverts commit d4c33720208346ee7983213fe764df3102b8a771. PATH inconsistencies and Host/Install arguments have been fixed in both LEDE and OpenWrt, so we can revert the revert. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index f0763cb1df..972a451c69 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,10 +37,9 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))