summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-08-22 17:18:36 +0000
committerSteven Barth <steven@midlink.org>2008-08-22 17:18:36 +0000
commit9c6a852939c4f16f5d82299ff7b3a10f15ac3db0 (patch)
tree070f5e179d8205f0d9c0807545f4de20660c1c64 /modules
parentdcf0f6146fb3beb47b4d677b29be5f13d86ea1e6 (diff)
Updated XML translation system, fixed some errors with multiline-translations
Thanks: Alina Friedrichsen
Diffstat (limited to 'modules')
-rw-r--r--modules/admin-core/luasrc/view/about.htm1
-rw-r--r--modules/freifunk/luasrc/i18n/freifunk.de.lua1
-rw-r--r--modules/freifunk/luasrc/i18n/freifunk.de.xml2
-rw-r--r--modules/rpc/Makefile2
-rw-r--r--modules/rpc/luasrc/controller/rpc.lua31
5 files changed, 37 insertions, 0 deletions
diff --git a/modules/admin-core/luasrc/view/about.htm b/modules/admin-core/luasrc/view/about.htm
index 5e102ced6..dfcfd6dba 100644
--- a/modules/admin-core/luasrc/view/about.htm
+++ b/modules/admin-core/luasrc/view/about.htm
@@ -31,6 +31,7 @@ $Id$
<ul style="font-weight: bold">
<li><a href="mailto:mail-at-antonpopov-dot-de">Anton "xyron" Popov</a></li>
<li><a href="mailto:florian-at-openwrt-dot-org">Florian Fainelli</a> (OpenWRT)</li>
+ <li><a href="mailto:x-alina-at-gmx-dot-net">Alina Friedrichsen</a></li>
</ul>
<br />
diff --git a/modules/freifunk/luasrc/i18n/freifunk.de.lua b/modules/freifunk/luasrc/i18n/freifunk.de.lua
index bb3d3a3d4..a47e61a63 100644
--- a/modules/freifunk/luasrc/i18n/freifunk.de.lua
+++ b/modules/freifunk/luasrc/i18n/freifunk.de.lua
@@ -3,6 +3,7 @@ public2 = [[Dies ist der Zugangspunkt ]]
public3 = [[Er wird betrieben von ]]
public4 = [[Weitere Informationen zur globalen Freifunkinitiative findest du unter]]
public5 = [[Hast du Interesse an diesem Projekt, dann wende dich an deine lokale Gemeinschaft]]
+public6 = [[Der Internetzugang über das experimentelle Freifunknetz ist an technische und organisatorische Bedingungen geknüpft und deshalb möglicherweise nicht (immer) gewährleistet.]]
location = [[Standort]]
mail = [[E-Mail]]
mail1 = [[Bitte unbedingt angeben!]]
diff --git a/modules/freifunk/luasrc/i18n/freifunk.de.xml b/modules/freifunk/luasrc/i18n/freifunk.de.xml
index 8312468a2..e947cba6c 100644
--- a/modules/freifunk/luasrc/i18n/freifunk.de.xml
+++ b/modules/freifunk/luasrc/i18n/freifunk.de.xml
@@ -7,6 +7,7 @@
<i18n:msg xml:id="public3">Er wird betrieben von </i18n:msg>
<i18n:msg xml:id="public4">Weitere Informationen zur globalen Freifunkinitiative findest du unter</i18n:msg>
<i18n:msg xml:id="public5">Hast du Interesse an diesem Projekt, dann wende dich an deine lokale Gemeinschaft</i18n:msg>
+<i18n:msg xml:id="public6">Der Internetzugang über das experimentelle Freifunknetz ist an technische und organisatorische Bedingungen geknüpft und deshalb möglicherweise nicht (immer) gewährleistet.</i18n:msg>
<i18n:msg xml:id="location">Standort</i18n:msg>
<i18n:msg xml:id="mail">E-Mail</i18n:msg>
@@ -21,4 +22,5 @@
<i18n:msg xml:id="cached">Cached</i18n:msg>
<i18n:msg xml:id="total">Gesamt</i18n:msg>
<i18n:msg xml:id="geocoord">Geokoordinaten</i18n:msg>
+
</i18n:msgs>
diff --git a/modules/rpc/Makefile b/modules/rpc/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/modules/rpc/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/modules/rpc/luasrc/controller/rpc.lua b/modules/rpc/luasrc/controller/rpc.lua
new file mode 100644
index 000000000..41d4c59f0
--- /dev/null
+++ b/modules/rpc/luasrc/controller/rpc.lua
@@ -0,0 +1,31 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+module("luci.controller.rpc", package.seeall)
+
+function index()
+ entry({"rpc", "uci"}, call("rpc_uci")).sysauth = "root"
+ entry({"rpc", "auth"}, call("rpc_auth"))
+end
+
+function rpc_proxy(tbl, jsonrpc, method, params, id)
+ local res = {luci.util.copcall(tbl[function], ...)}
+ local stat = table.remove(res, 1)
+
+ if not stat then
+ return nil, {code=-32602, message="Invalid params.", data=table.remove(res, 1)}
+ else
+ return res, nil
+ end
+end \ No newline at end of file