summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-08 10:47:39 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-08 10:47:39 +0200
commit1575d659a14c393a46cef8a2e917945b1c676726 (patch)
tree2e15565db5e391ae7394d9db91e2d77db53c42af /modules
parent7c5006db68b1f12bbc9f5b5e1905669069a2375d (diff)
parent4580faaa5e1e3988ea806deafb70071a58250473 (diff)
Merge pull request #735 from kdarbyshirebryant/srcdietfix
luci-base: fix lua interpreter location
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index a9c5e71cba..f0763cb1df 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,10 @@ define Host/Compile
endef
define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
$(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))