summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-03 13:06:54 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-03 18:07:43 +0200
commit87a7570690f7aeffb1aff01f320973c9acb668d3 (patch)
treecb1d0ff01c9b9a351680a7f78c05bf6cfb04a59b /modules
parent185e4c1332ae65ffdcaf96597f729d57e890cead (diff)
luci-base: use default install paths for host utils
Also, don't make any assumptions about the staging dir lua and LuaSrcDiet were installed to. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index f0763cb1d..972a451c6 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,10 +37,9 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))