summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-freifunk-community/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-freifunk-community/Makefile
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-freifunk-community/Makefile')
-rw-r--r--modules/luci-mod-freifunk-community/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/luci-mod-freifunk-community/Makefile b/modules/luci-mod-freifunk-community/Makefile
new file mode 100644
index 0000000000..ad6c4ce2ef
--- /dev/null
+++ b/modules/luci-mod-freifunk-community/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Freifunk Community Meta-Package
+LUCI_DEPENDS:= \
+ +iptables-mod-nat-extra +iptables-mod-ipopt +luci-app-splash \
+ +olsrd +olsrd-mod-dyn-gw-plain +olsrd-mod-jsoninfo +olsrd-mod-nameservice \
+ +olsrd-mod-watchdog +kmod-tun +ip +freifunk-watchdog +luci-app-olsr \
+ +luci-app-olsr-services +freifunk-gwcheck +freifunk-mapupdate
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
+