summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua')
-rw-r--r--modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua48
1 files changed, 48 insertions, 0 deletions
diff --git a/modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua b/modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua
new file mode 100644
index 000000000..9d6a38ed4
--- /dev/null
+++ b/modules/luci-mod-admin-mini/luasrc/controller/mini/index.lua
@@ -0,0 +1,48 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.mini.index", package.seeall)
+
+function index()
+ local root = node()
+ if not root.lock then
+ root.target = alias("mini")
+ root.index = true
+ end
+
+ entry({"about"}, template("about"))
+
+ local page = entry({"mini"}, alias("mini", "index"), _("Essentials"), 10)
+ page.sysauth = "root"
+ page.sysauth_authenticator = "htmlauth"
+ page.index = true
+
+ entry({"mini", "index"}, alias("mini", "index", "index"), _("Overview"), 10).index = true
+ entry({"mini", "index", "index"}, form("mini/index"), _("General"), 1).ignoreindex = true
+ entry({"mini", "index", "luci"}, cbi("mini/luci", {autoapply=true}), _("Settings"), 10)
+ entry({"mini", "index", "logout"}, call("action_logout"), _("Logout"))
+end
+
+function action_logout()
+ local dsp = require "luci.dispatcher"
+ local sauth = require "luci.sauth"
+ if dsp.context.authsession then
+ sauth.kill(dsp.context.authsession)
+ dsp.context.urltoken.stok = nil
+ end
+
+ luci.http.header("Set-Cookie", "sysauth=; path=" .. dsp.build_url())
+ luci.http.redirect(luci.dispatcher.build_url())
+end