summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-admin-full/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-admin-full/src/Makefile
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-admin-full/src/Makefile')
-rw-r--r--modules/luci-mod-admin-full/src/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/luci-mod-admin-full/src/Makefile b/modules/luci-mod-admin-full/src/Makefile
new file mode 100644
index 0000000000..47045fc5c4
--- /dev/null
+++ b/modules/luci-mod-admin-full/src/Makefile
@@ -0,0 +1,14 @@
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -c -o $@ $<
+
+clean:
+ rm -f luci-bwc *.o
+
+luci-bwc: luci-bwc.o
+ $(CC) $(LDFLAGS) -shared -o $@ $^
+
+compile: luci-bwc
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/bin
+ cp luci-bwc $(DESTDIR)/usr/bin/luci-bwc