summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-admin-full/luasrc/controller/admin/status.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-admin-full/luasrc/controller/admin/status.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-admin-full/luasrc/controller/admin/status.lua')
-rw-r--r--modules/luci-mod-admin-full/luasrc/controller/admin/status.lua164
1 files changed, 164 insertions, 0 deletions
diff --git a/modules/luci-mod-admin-full/luasrc/controller/admin/status.lua b/modules/luci-mod-admin-full/luasrc/controller/admin/status.lua
new file mode 100644
index 0000000000..89ebda7353
--- /dev/null
+++ b/modules/luci-mod-admin-full/luasrc/controller/admin/status.lua
@@ -0,0 +1,164 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2011 Jo-Philipp Wich <xm@subsignal.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.admin.status", package.seeall)
+
+function index()
+ entry({"admin", "status"}, alias("admin", "status", "overview"), _("Status"), 20).index = true
+ entry({"admin", "status", "overview"}, template("admin_status/index"), _("Overview"), 1)
+ entry({"admin", "status", "iptables"}, call("action_iptables"), _("Firewall"), 2).leaf = true
+ entry({"admin", "status", "routes"}, template("admin_status/routes"), _("Routes"), 3)
+ entry({"admin", "status", "syslog"}, call("action_syslog"), _("System Log"), 4)
+ entry({"admin", "status", "dmesg"}, call("action_dmesg"), _("Kernel Log"), 5)
+ entry({"admin", "status", "processes"}, cbi("admin_status/processes"), _("Processes"), 6)
+
+ entry({"admin", "status", "realtime"}, alias("admin", "status", "realtime", "load"), _("Realtime Graphs"), 7)
+
+ entry({"admin", "status", "realtime", "load"}, template("admin_status/load"), _("Load"), 1).leaf = true
+ entry({"admin", "status", "realtime", "load_status"}, call("action_load")).leaf = true
+
+ entry({"admin", "status", "realtime", "bandwidth"}, template("admin_status/bandwidth"), _("Traffic"), 2).leaf = true
+ entry({"admin", "status", "realtime", "bandwidth_status"}, call("action_bandwidth")).leaf = true
+
+ entry({"admin", "status", "realtime", "wireless"}, template("admin_status/wireless"), _("Wireless"), 3).leaf = true
+ entry({"admin", "status", "realtime", "wireless_status"}, call("action_wireless")).leaf = true
+
+ entry({"admin", "status", "realtime", "connections"}, template("admin_status/connections"), _("Connections"), 4).leaf = true
+ entry({"admin", "status", "realtime", "connections_status"}, call("action_connections")).leaf = true
+
+ entry({"admin", "status", "nameinfo"}, call("action_nameinfo")).leaf = true
+end
+
+function action_syslog()
+ local syslog = luci.sys.syslog()
+ luci.template.render("admin_status/syslog", {syslog=syslog})
+end
+
+function action_dmesg()
+ local dmesg = luci.sys.dmesg()
+ luci.template.render("admin_status/dmesg", {dmesg=dmesg})
+end
+
+function action_iptables()
+ if luci.http.formvalue("zero") then
+ if luci.http.formvalue("zero") == "6" then
+ luci.util.exec("ip6tables -Z")
+ else
+ luci.util.exec("iptables -Z")
+ end
+ luci.http.redirect(
+ luci.dispatcher.build_url("admin", "status", "iptables")
+ )
+ elseif luci.http.formvalue("restart") == "1" then
+ luci.util.exec("/etc/init.d/firewall reload")
+ luci.http.redirect(
+ luci.dispatcher.build_url("admin", "status", "iptables")
+ )
+ else
+ luci.template.render("admin_status/iptables")
+ end
+end
+
+function action_bandwidth(iface)
+ luci.http.prepare_content("application/json")
+
+ local bwc = io.popen("luci-bwc -i %q 2>/dev/null" % iface)
+ if bwc then
+ luci.http.write("[")
+
+ while true do
+ local ln = bwc:read("*l")
+ if not ln then break end
+ luci.http.write(ln)
+ end
+
+ luci.http.write("]")
+ bwc:close()
+ end
+end
+
+function action_wireless(iface)
+ luci.http.prepare_content("application/json")
+
+ local bwc = io.popen("luci-bwc -r %q 2>/dev/null" % iface)
+ if bwc then
+ luci.http.write("[")
+
+ while true do
+ local ln = bwc:read("*l")
+ if not ln then break end
+ luci.http.write(ln)
+ end
+
+ luci.http.write("]")
+ bwc:close()
+ end
+end
+
+function action_load()
+ luci.http.prepare_content("application/json")
+
+ local bwc = io.popen("luci-bwc -l 2>/dev/null")
+ if bwc then
+ luci.http.write("[")
+
+ while true do
+ local ln = bwc:read("*l")
+ if not ln then break end
+ luci.http.write(ln)
+ end
+
+ luci.http.write("]")
+ bwc:close()
+ end
+end
+
+function action_connections()
+ local sys = require "luci.sys"
+
+ luci.http.prepare_content("application/json")
+
+ luci.http.write("{ connections: ")
+ luci.http.write_json(sys.net.conntrack())
+
+ local bwc = io.popen("luci-bwc -c 2>/dev/null")
+ if bwc then
+ luci.http.write(", statistics: [")
+
+ while true do
+ local ln = bwc:read("*l")
+ if not ln then break end
+ luci.http.write(ln)
+ end
+
+ luci.http.write("]")
+ bwc:close()
+ end
+
+ luci.http.write(" }")
+end
+
+function action_nameinfo(...)
+ local i
+ local rv = { }
+ for i = 1, select('#', ...) do
+ local addr = select(i, ...)
+ local fqdn = nixio.getnameinfo(addr)
+ rv[addr] = fqdn or (addr:match(":") and "[%s]" % addr or addr)
+ end
+
+ luci.http.prepare_content("application/json")
+ luci.http.write_json(rv)
+end