summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-base/src/Makefile
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-base/src/Makefile')
-rw-r--r--modules/luci-base/src/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
new file mode 100644
index 000000000..7bb7f2ebe
--- /dev/null
+++ b/modules/luci-base/src/Makefile
@@ -0,0 +1,21 @@
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -c -o $@ $<
+
+clean:
+ rm -f po2lmo parser.so version.lua *.o
+
+po2lmo: po2lmo.o template_lmo.o
+ $(CC) $(LDFLAGS) -o $@ $^
+
+parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o
+ $(CC) $(LDFLAGS) -shared -o $@ $^
+
+version.lua:
+ ./mkversion.sh $@ $(LUCI_VERSION)
+
+compile: parser.so version.lua
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/lib/lua/luci/template
+ cp parser.so $(DESTDIR)/usr/lib/lua/luci/template/parser.so
+ cp version.lua $(DESTDIR)/usr/lib/lua/luci/version.lua