summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/src/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-03-10 19:50:58 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2016-03-10 19:50:58 +0200
commit7553654bb10af9206cff9837a485b828d1998213 (patch)
treea624ec0aa1e192841c8752b534efd92b9586a3c9 /modules/luci-base/src/Makefile
parentac9b31ca462b5662e98a0ac6b57fb49c4c4e32de (diff)
LuCI: Display the proper LuCI git branch in GUI
Adjust luci.mk and luci-base to find out correctly if Luci is built from master or from a branch. Display that value in the footer and the overview page. * Evaluate the git branch in luci.mk and pass that to LuCI submodules as a make variable. Use branch name, ignore tags. * Deprecate svn detection in luci-base's mkversion.sh that generates version.lua. Simply use the value passed by make. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'modules/luci-base/src/Makefile')
-rw-r--r--modules/luci-base/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
index 7bb7f2ebe0..03e887e1d5 100644
--- a/modules/luci-base/src/Makefile
+++ b/modules/luci-base/src/Makefile
@@ -11,7 +11,7 @@ parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o
$(CC) $(LDFLAGS) -shared -o $@ $^
version.lua:
- ./mkversion.sh $@ $(LUCI_VERSION)
+ ./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)"
compile: parser.so version.lua