summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/luasrc/sgi
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-base/luasrc/sgi
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-base/luasrc/sgi')
-rw-r--r--modules/luci-base/luasrc/sgi/cgi.lua95
-rw-r--r--modules/luci-base/luasrc/sgi/uhttpd.lua105
2 files changed, 200 insertions, 0 deletions
diff --git a/modules/luci-base/luasrc/sgi/cgi.lua b/modules/luci-base/luasrc/sgi/cgi.lua
new file mode 100644
index 000000000..04ae9aa59
--- /dev/null
+++ b/modules/luci-base/luasrc/sgi/cgi.lua
@@ -0,0 +1,95 @@
+--[[
+LuCI - SGI-Module for CGI
+
+Description:
+Server Gateway Interface for CGI
+
+FileId:
+$Id$
+
+License:
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+exectime = os.clock()
+module("luci.sgi.cgi", package.seeall)
+local ltn12 = require("luci.ltn12")
+require("nixio.util")
+require("luci.http")
+require("luci.sys")
+require("luci.dispatcher")
+
+-- Limited source to avoid endless blocking
+local function limitsource(handle, limit)
+ limit = limit or 0
+ local BLOCKSIZE = ltn12.BLOCKSIZE
+
+ return function()
+ if limit < 1 then
+ handle:close()
+ return nil
+ else
+ local read = (limit > BLOCKSIZE) and BLOCKSIZE or limit
+ limit = limit - read
+
+ local chunk = handle:read(read)
+ if not chunk then handle:close() end
+ return chunk
+ end
+ end
+end
+
+function run()
+ local r = luci.http.Request(
+ luci.sys.getenv(),
+ limitsource(io.stdin, tonumber(luci.sys.getenv("CONTENT_LENGTH"))),
+ ltn12.sink.file(io.stderr)
+ )
+
+ local x = coroutine.create(luci.dispatcher.httpdispatch)
+ local hcache = ""
+ local active = true
+
+ while coroutine.status(x) ~= "dead" do
+ local res, id, data1, data2 = coroutine.resume(x, r)
+
+ if not res then
+ print("Status: 500 Internal Server Error")
+ print("Content-Type: text/plain\n")
+ print(id)
+ break;
+ end
+
+ if active then
+ if id == 1 then
+ io.write("Status: " .. tostring(data1) .. " " .. data2 .. "\r\n")
+ elseif id == 2 then
+ hcache = hcache .. data1 .. ": " .. data2 .. "\r\n"
+ elseif id == 3 then
+ io.write(hcache)
+ io.write("\r\n")
+ elseif id == 4 then
+ io.write(tostring(data1 or ""))
+ elseif id == 5 then
+ io.flush()
+ io.close()
+ active = false
+ elseif id == 6 then
+ data1:copyz(nixio.stdout, data2)
+ data1:close()
+ end
+ end
+ end
+end
diff --git a/modules/luci-base/luasrc/sgi/uhttpd.lua b/modules/luci-base/luasrc/sgi/uhttpd.lua
new file mode 100644
index 000000000..db8780f7e
--- /dev/null
+++ b/modules/luci-base/luasrc/sgi/uhttpd.lua
@@ -0,0 +1,105 @@
+--[[
+LuCI - Server Gateway Interface for the uHTTPd server
+
+Copyright 2010 Jo-Philipp Wich <xm@subsignal.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+
+require "nixio.util"
+require "luci.http"
+require "luci.sys"
+require "luci.dispatcher"
+require "luci.ltn12"
+
+function handle_request(env)
+ exectime = os.clock()
+ local renv = {
+ CONTENT_LENGTH = env.CONTENT_LENGTH,
+ CONTENT_TYPE = env.CONTENT_TYPE,
+ REQUEST_METHOD = env.REQUEST_METHOD,
+ REQUEST_URI = env.REQUEST_URI,
+ PATH_INFO = env.PATH_INFO,
+ SCRIPT_NAME = env.SCRIPT_NAME:gsub("/+$", ""),
+ SCRIPT_FILENAME = env.SCRIPT_NAME,
+ SERVER_PROTOCOL = env.SERVER_PROTOCOL,
+ QUERY_STRING = env.QUERY_STRING
+ }
+
+ local k, v
+ for k, v in pairs(env.headers) do
+ k = k:upper():gsub("%-", "_")
+ renv["HTTP_" .. k] = v
+ end
+
+ local len = tonumber(env.CONTENT_LENGTH) or 0
+ local function recv()
+ if len > 0 then
+ local rlen, rbuf = uhttpd.recv(4096)
+ if rlen >= 0 then
+ len = len - rlen
+ return rbuf
+ end
+ end
+ return nil
+ end
+
+ local send = uhttpd.send
+
+ local req = luci.http.Request(
+ renv, recv, luci.ltn12.sink.file(io.stderr)
+ )
+
+
+ local x = coroutine.create(luci.dispatcher.httpdispatch)
+ local hcache = { }
+ local active = true
+
+ while coroutine.status(x) ~= "dead" do
+ local res, id, data1, data2 = coroutine.resume(x, req)
+
+ if not res then
+ send("Status: 500 Internal Server Error\r\n")
+ send("Content-Type: text/plain\r\n\r\n")
+ send(tostring(id))
+ break
+ end
+
+ if active then
+ if id == 1 then
+ send("Status: ")
+ send(tostring(data1))
+ send(" ")
+ send(tostring(data2))
+ send("\r\n")
+ elseif id == 2 then
+ hcache[data1] = data2
+ elseif id == 3 then
+ for k, v in pairs(hcache) do
+ send(tostring(k))
+ send(": ")
+ send(tostring(v))
+ send("\r\n")
+ end
+ send("\r\n")
+ elseif id == 4 then
+ send(tostring(data1 or ""))
+ elseif id == 5 then
+ active = false
+ elseif id == 6 then
+ data1:copyz(nixio.stdout, data2)
+ end
+ end
+ end
+end