summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/luasrc/init.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-base/luasrc/init.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-base/luasrc/init.lua')
-rw-r--r--modules/luci-base/luasrc/init.lua39
1 files changed, 39 insertions, 0 deletions
diff --git a/modules/luci-base/luasrc/init.lua b/modules/luci-base/luasrc/init.lua
new file mode 100644
index 000000000..4d66e8673
--- /dev/null
+++ b/modules/luci-base/luasrc/init.lua
@@ -0,0 +1,39 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Description:
+Main class
+
+FileId:
+$Id$
+
+License:
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+
+local require = require
+
+-- Make sure that bitlib is loaded
+if not _G.bit then
+ _G.bit = require "bit"
+end
+
+module "luci"
+
+local v = require "luci.version"
+
+__version__ = v.luciversion or "trunk"
+__appname__ = v.luciname or "LuCI"