summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-05 01:42:51 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-05 01:44:02 +0200
commitd4c33720208346ee7983213fe764df3102b8a771 (patch)
tree2aba8f1d8143375d15606016a81624c0c8e75526 /modules/luci-base/Makefile
parentdcb2a0e68036b501a4f62633d71ff7c2815b652e (diff)
Revert "luci-base: use default install paths for host utils"
This reverts commit 87a7570690f7aeffb1aff01f320973c9acb668d3. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'modules/luci-base/Makefile')
-rw-r--r--modules/luci-base/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 972a451c6..f0763cb1d 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,10 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))