summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/Makefile
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-05-29 14:56:51 +0100
committerKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-06-03 10:24:09 +0100
commit4580faaa5e1e3988ea806deafb70071a58250473 (patch)
tree386b2c74f32c0b00646bcaf12943a7092efe6039 /modules/luci-base/Makefile
parent1709800150565fd027a3a9b752687439f53460ab (diff)
luci-base: fix lua interpreter location
An lua interpreter is required on the building host to run the luasrcdiet lua script. Due to a build change, the interpreter was not being installed to the correct location. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'modules/luci-base/Makefile')
-rw-r--r--modules/luci-base/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index a9c5e71cb..f0763cb1d 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,10 @@ define Host/Compile
endef
define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
$(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))