summaryrefslogtreecommitdiffhomepage
path: root/modules/base/luasrc/debug.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/base/luasrc/debug.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/base/luasrc/debug.lua')
-rw-r--r--modules/base/luasrc/debug.lua37
1 files changed, 0 insertions, 37 deletions
diff --git a/modules/base/luasrc/debug.lua b/modules/base/luasrc/debug.lua
deleted file mode 100644
index 8ff1bb6981..0000000000
--- a/modules/base/luasrc/debug.lua
+++ /dev/null
@@ -1,37 +0,0 @@
-local debug = require "debug"
-local io = require "io"
-local collectgarbage, floor = collectgarbage, math.floor
-
-module "luci.debug"
-__file__ = debug.getinfo(1, 'S').source:sub(2)
-
--- Enables the memory tracer with given flags and returns a function to disable the tracer again
-function trap_memtrace(flags, dest)
- flags = flags or "clr"
- local tracefile = io.open(dest or "/tmp/memtrace", "w")
- local peak = 0
-
- local function trap(what, line)
- local info = debug.getinfo(2, "Sn")
- local size = floor(collectgarbage("count"))
- if size > peak then
- peak = size
- end
- if tracefile then
- tracefile:write(
- "[", what, "] ", info.source, ":", (line or "?"), "\t",
- (info.namewhat or ""), "\t",
- (info.name or ""), "\t",
- size, " (", peak, ")\n"
- )
- end
- end
-
- debug.sethook(trap, flags)
-
- return function()
- debug.sethook()
- tracefile:close()
- end
-end
-