summaryrefslogtreecommitdiffhomepage
path: root/modules/admin-full/luasrc/controller/admin/index.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/admin-full/luasrc/controller/admin/index.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/admin-full/luasrc/controller/admin/index.lua')
-rw-r--r--modules/admin-full/luasrc/controller/admin/index.lua49
1 files changed, 0 insertions, 49 deletions
diff --git a/modules/admin-full/luasrc/controller/admin/index.lua b/modules/admin-full/luasrc/controller/admin/index.lua
deleted file mode 100644
index 4e832529d9..0000000000
--- a/modules/admin-full/luasrc/controller/admin/index.lua
+++ /dev/null
@@ -1,49 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-module("luci.controller.admin.index", package.seeall)
-
-function index()
- local root = node()
- if not root.target then
- root.target = alias("admin")
- root.index = true
- end
-
- local page = node("admin")
- page.target = firstchild()
- page.title = _("Administration")
- page.order = 10
- page.sysauth = "root"
- page.sysauth_authenticator = "htmlauth"
- page.ucidata = true
- page.index = true
-
- -- Empty services menu to be populated by addons
- entry({"admin", "services"}, firstchild(), _("Services"), 40).index = true
-
- entry({"admin", "logout"}, call("action_logout"), _("Logout"), 90)
-end
-
-function action_logout()
- local dsp = require "luci.dispatcher"
- local sauth = require "luci.sauth"
- if dsp.context.authsession then
- sauth.kill(dsp.context.authsession)
- dsp.context.urltoken.stok = nil
- end
-
- luci.http.header("Set-Cookie", "sysauth=; path=" .. dsp.build_url())
- luci.http.redirect(luci.dispatcher.build_url())
-end