summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-03-03 09:28:44 +0100
committerJo-Philipp Wich <jo@mein.io>2020-03-03 15:21:55 +0100
commitca558f4f93451de7afb2a85c017051cb807b3329 (patch)
tree4147335186f70401f2b72770c61e753e77b40d93 /luci.mk
parent9b25031cb29bd59561e550daccb69935834d7d63 (diff)
build: reload rpcd in package postinstall
Send a SIGHUP to rpcd after installing LuCI packages to reload ACL rules. Also remove redundant code while we're at it. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk13
1 files changed, 2 insertions, 11 deletions
diff --git a/luci.mk b/luci.mk
index 54f3835b4..522a21e76 100644
--- a/luci.mk
+++ b/luci.mk
@@ -221,25 +221,16 @@ define Package/$(PKG_NAME)/install
else true; fi
endef
-ifneq ($(LUCI_DEFAULTS),)
+ifndef Package/$(PKG_NAME)/postinst
define Package/$(PKG_NAME)/postinst
[ -n "$${IPKG_INSTROOT}" ] || {$(foreach script,$(LUCI_DEFAULTS),
(. /etc/uci-defaults/$(script)) && rm -f /etc/uci-defaults/$(script))
rm -f /tmp/luci-indexcache
rm -rf /tmp/luci-modulecache/
+ killall -HUP rpcd 2>/dev/null
exit 0
}
endef
-else
-ifndef Package/$(PKG_NAME)/postinst
-define Package/$(PKG_NAME)/postinst
-[ -n "$${IPKG_INSTROOT}" ] || {
- rm -f /tmp/luci-indexcache
- rm -rf /tmp/luci-modulecache/
- exit 0
-}
-endef
-endif
endif