summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-02-21 09:25:00 +0100
committerFlorian Eckert <fe@dev.tdt.de>2020-02-27 15:50:46 +0100
commitb448008b4744a29ad23812ba37c3ec908d7134d9 (patch)
tree24ba72a0dc59c688882cafcf0ad60a5d89dfd144 /luci.mk
parent151787b561bce39f505d0f5753d0f80d2b796ba3 (diff)
luci.mk: Only install a default post-install script if there is none defined
If a postinst script is defined in the package Makefile, it will not be included because it will be replaced by the default postinst script. To solve the problem, we now check, if we have a postinst script. And if so, it will be installed instead of the default postinst script. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/luci.mk b/luci.mk
index 6e299aaae..54f3835b4 100644
--- a/luci.mk
+++ b/luci.mk
@@ -231,6 +231,7 @@ define Package/$(PKG_NAME)/postinst
}
endef
else
+ifndef Package/$(PKG_NAME)/postinst
define Package/$(PKG_NAME)/postinst
[ -n "$${IPKG_INSTROOT}" ] || {
rm -f /tmp/luci-indexcache
@@ -239,6 +240,7 @@ define Package/$(PKG_NAME)/postinst
}
endef
endif
+endif
LUCI_BUILD_PACKAGES := $(PKG_NAME)