diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2015-01-18 17:27:13 +0100 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2015-01-18 17:27:16 +0100 |
commit | 52ecc90b3129c72a856c3d16534276ab7e192179 (patch) | |
tree | 4e4131cf4dbef7edde65ae38ab419e83457ea427 /luci.mk | |
parent | 30d45d0c0e0a08725b017693460a6d70379a68ac (diff) |
luci.mk: expose option to override PKGARCH (#295)
Also mark packages without src/ as arch independant by default.
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -1,5 +1,5 @@ # -# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org> +# Copyright (C) 2008-2015 The LuCI Team <luci@lists.subsignal.org> # # This is free software, licensed under the Apache License, Version 2.0 . # @@ -9,6 +9,7 @@ LUCI_TYPE?=$(word 2,$(subst -, ,$(LUCI_NAME))) LUCI_BASENAME?=$(patsubst luci-$(LUCI_TYPE)-%,%,$(LUCI_NAME)) LUCI_LANGUAGES:=$(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*))) LUCI_DEFAULTS:=$(notdir $(wildcard ${CURDIR}/root/etc/uci-defaults/*)) +LUCI_PKGARCH?=$(if $(realpath src/Makefile),,all) # Language code titles LUCI_LANG.ca=CatalĂ (Catalan) @@ -80,6 +81,7 @@ define Package/$(PKG_NAME) SUBMENU:=$(if $(LUCI_MENU.$(LUCI_TYPE)),$(LUCI_MENU.$(LUCI_TYPE)),$(LUCI_MENU.app)) TITLE:=$(if $(LUCI_TITLE),$(LUCI_TITLE),LuCI $(LUCI_NAME) $(LUCI_TYPE)) DEPENDS:=$(LUCI_DEPENDS) + $(if $(LUCI_PKGARCH),PKGARCH:=$(LUCI_PKGARCH)) endef ifneq ($(LUCI_DESCRIPTION),) @@ -181,6 +183,7 @@ define LuciTranslation HIDDEN:=1 DEFAULT:=LUCI_LANG_$(1)||ALL DEPENDS:=$(PKG_NAME) + PKGARCH:=all endef define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/description |