diff options
author | Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk> | 2016-05-29 14:56:51 +0100 |
---|---|---|
committer | Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk> | 2016-06-03 10:24:09 +0100 |
commit | 4580faaa5e1e3988ea806deafb70071a58250473 (patch) | |
tree | 386b2c74f32c0b00646bcaf12943a7092efe6039 /luci.mk | |
parent | 1709800150565fd027a3a9b752687439f53460ab (diff) |
luci-base: fix lua interpreter location
An lua interpreter is required on the building host to run the
luasrcdiet lua script. Due to a build change, the interpreter was not
being installed to the correct location.
Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -150,7 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci define SrcDiet $(FIND) $(1) -type f -name '*.lua' | while read src; do \ - if $(STAGING_DIR_HOST)/bin/lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet \ + if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \ --noopt-binequiv -o "$$$$src.o" "$$$$src"; \ then mv "$$$$src.o" "$$$$src"; fi; \ done |