diff options
author | Hannu Nyman <hannu.nyman@iki.fi> | 2016-03-10 19:50:58 +0200 |
---|---|---|
committer | Hannu Nyman <hannu.nyman@iki.fi> | 2016-03-10 19:50:58 +0200 |
commit | 7553654bb10af9206cff9837a485b828d1998213 (patch) | |
tree | a624ec0aa1e192841c8752b534efd92b9586a3c9 /luci.mk | |
parent | ac9b31ca462b5662e98a0ac6b57fb49c4c4e32de (diff) |
LuCI: Display the proper LuCI git branch in GUI
Adjust luci.mk and luci-base to find out correctly if Luci is built
from master or from a branch. Display that value in the footer and
the overview page.
* Evaluate the git branch in luci.mk and pass that to LuCI submodules
as a make variable. Use branch name, ignore tags.
* Deprecate svn detection in luci-base's mkversion.sh that generates
version.lua. Simply use the value passed by make.
Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 15 |
1 files changed, 14 insertions, 1 deletions
@@ -66,6 +66,19 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \ echo "$$revision" \ ))) +PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \ + variant="LuCI"; \ + if git log -1 >/dev/null 2>/dev/null; then \ + branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null)"; \ + if [ "$$branch" != "master" ]; then \ + variant="LuCI $$branch branch"; \ + else \ + variant="LuCI Master"; \ + fi; \ + fi; \ + echo "$$variant" \ +))) + PKG_RELEASE?=1 PKG_INSTALL:=$(if $(realpath src/Makefile),1) PKG_BUILD_DEPENDS += lua/host luci-base/host $(LUCI_BUILD_DEPENDS) @@ -121,7 +134,7 @@ endef ifneq ($(wildcard ${CURDIR}/src/Makefile),) MAKE_PATH := src/ - MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)" + MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)" LUCI_GITBRANCH="$(PKG_GITBRANCH)" define Build/Compile $(call Build/Compile/Default,clean compile) |