summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2017-08-02 16:45:26 +0200
committerFlorian Eckert <fe@dev.tdt.de>2017-08-11 13:08:41 +0200
commit713d463248773f4c0d8fee1d9c2b8dc0ff0de32c (patch)
treea7ec816e0f85dedaeb23c7acd39acc06b0c80f27 /luci.mk
parentbf407f087cde592631bd0c95948e32cbd0efab08 (diff)
luci.mk: sort languages in lexical order
sorting language in .config by lexical order Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 1ddb73d49..0b2ec4e70 100644
--- a/luci.mk
+++ b/luci.mk
@@ -7,7 +7,7 @@
LUCI_NAME?=$(notdir ${CURDIR})
LUCI_TYPE?=$(word 2,$(subst -, ,$(LUCI_NAME)))
LUCI_BASENAME?=$(patsubst luci-$(LUCI_TYPE)-%,%,$(LUCI_NAME))
-LUCI_LANGUAGES:=$(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*)))
+LUCI_LANGUAGES:=$(sort $(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*))))
LUCI_DEFAULTS:=$(notdir $(wildcard ${CURDIR}/root/etc/uci-defaults/*))
LUCI_PKGARCH?=$(if $(realpath src/Makefile),,all)