summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-10 14:20:18 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-10 14:20:18 +0100
commita36807b942a956687327d2069a7a8ff12e145473 (patch)
tree2a8fd2ea80279912a53f4ae919ca39534110c6be /luci.mk
parentc97011fd970982be798801008b6e93343f0fdd9d (diff)
build: fix language dependency handling
Turn language selection into a tristate, this allows building language packages without having them included in the image. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 12e9b02ef..1efae9a1f 100644
--- a/luci.mk
+++ b/luci.mk
@@ -98,7 +98,7 @@ ifeq ($(PKG_NAME),luci-base)
menu "Translations"$(foreach lang,$(LUCI_LANGUAGES),
config LUCI_LANG_$(lang)
- bool "$(shell echo '$(LUCI_LANG.$(lang))' | sed -e 's/^.* (\(.*\))$$/\1/') ($(lang))")
+ tristate "$(shell echo '$(LUCI_LANG.$(lang))' | sed -e 's/^.* (\(.*\))$$/\1/') ($(lang))")
endmenu
endef
@@ -179,6 +179,7 @@ define LuciTranslation
CATEGORY:=LuCI
TITLE:=$(PKG_NAME) - $(1) translation
HIDDEN:=1
+ DEFAULT:=m if ALL||LUCI_LANG_$(1)
endef
define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/install