diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2015-01-10 23:36:26 +0100 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2015-01-10 23:36:26 +0100 |
commit | 1ce2d8f46af0673068a8057dbeb76af9c477ad55 (patch) | |
tree | ceb23fe8ca1ddf6ca18fc1565b146849c2c6b4e1 /luci.mk | |
parent | c5477f717dd50a9a2c87fa7f0cc0cbc03a2047cc (diff) |
build: rework language dependencies
Rework the language package dependencies to avoid introducing unnecessary
depends. The luci-i18n-$app-$lang packages now depend on luci-$app.
* When a language is selected as <*> then the language packs for each
enabled LuCI module are built into the image
* When a language is selected as <m> then the language packs for each
enabled LuCI module are built as package
* When CONFIG_ALL is set (e.g. release builds, snapshots) then all
language packs are built
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -79,7 +79,7 @@ define Package/$(PKG_NAME) CATEGORY:=LuCI SUBMENU:=$(if $(LUCI_MENU.$(LUCI_TYPE)),$(LUCI_MENU.$(LUCI_TYPE)),$(LUCI_MENU.app)) TITLE:=$(if $(LUCI_TITLE),$(LUCI_TITLE),LuCI $(LUCI_NAME) $(LUCI_TYPE)) - DEPENDS:=$(foreach lang,$(LUCI_LANGUAGES),+LUCI_LANG_$(lang):luci-i18n-$(LUCI_BASENAME)-$(lang)) $(LUCI_DEPENDS) + DEPENDS:=$(LUCI_DEPENDS) endef ifneq ($(LUCI_DESCRIPTION),) @@ -179,7 +179,12 @@ define LuciTranslation CATEGORY:=LuCI TITLE:=$(PKG_NAME) - $(1) translation HIDDEN:=1 - DEFAULT:=m if ALL||LUCI_LANG_$(1) + DEFAULT:=LUCI_LANG_$(1)||ALL + DEPENDS:=$(PKG_NAME) + endef + + define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/description + $(LUCI_LANG.$(1)) endef define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/install |