diff options
author | Jo-Philipp Wich <jo@mein.io> | 2017-02-20 14:34:16 +0100 |
---|---|---|
committer | Jo-Philipp Wich <jo@mein.io> | 2017-02-20 14:34:16 +0100 |
commit | 7942a23c814ed482982d94cceed641a8b68eb5f4 (patch) | |
tree | af6b63752a08f3d850f493248fc6d5ea408b1576 /luci.mk | |
parent | 05c5924434786c6720e0a497215fce0337d57d82 (diff) |
luci.mk: only use remote branch detection
LEDE's scripts/feeds script creates local branches named after the checked
out commit hash, confusing local branch detection.
Solely use remote branch detection to avoid misidentifying such cases.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 5 |
1 files changed, 2 insertions, 3 deletions
@@ -70,9 +70,8 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \ PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \ variant="LuCI"; \ if git log -1 >/dev/null 2>/dev/null; then \ - branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null || \ - git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \ - sed -e 's|^.*/||; s| .*||; q')"; \ + branch="$$(git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \ + sed -rne 's|^[^/]+/([^ ]+) [a-f0-9]{40} .+$$|\1|p' | head -n1)"; \ if [ "$$branch" != "master" ]; then \ variant="LuCI $$branch branch"; \ else \ |